php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25412 #15702,#19327 still exist in php 4.3.3 ?
Submitted: 2003-09-07 07:00 UTC Modified: 2003-09-07 11:03 UTC
From: birdfly2000 at 163 dot com Assigned:
Status: Not a bug Package: Java related
PHP Version: 4.3.3 OS: redhat 7.1
Private report: No CVE-ID: None
 [2003-09-07 07:00 UTC] birdfly2000 at 163 dot com
Description:
------------
Hello,
   I have a www server, it's configuration is redhat 7.1,apache 1.3.27,and jdk 1.3.1_06.
Now, i want to compile  php4.1.2 with  jdk1.3.1_06  support and get some problems as follow link says.
http://bugs.php.net/bug.php?id=19327
http://bugs.php.net/bug.php?id=15702

Fatal error: java.lang.UnsatisfiedLinkError: no php_java in java.library.path in 
 /www/www.mydomain.com/jver.php on line 4

i make the symbolic link 
$extensiondir$/java.so to $extensiondir$/libphp_java.so
and restart the apache /apache/bin/apachect restart ,but the error still exist.

In this page,   http://www.php.net/ChangeLog-4.php#4.3.3
it says bug #15702 fixed ,so i upgrade php4.1.2  to php 4.3.3 . but the same error still exist.

LD_LIBRARY_PATH=LD_LIBRARY_PATH=/usr/oracle/lib:/lib:/usr/lib:/usr/local/lib:/usr/local/apache/libexec:/usr/java/jdk1.3.1_06/jre/lib/i38
6/native_threads:/usr/java/jdk1.3.1_06/jre/lib/i386:/usr/java/jdk1.3.1_06/jre/lib/i386/hotspot

The content of /etc/ld.so.conf file 
/usr/lib
/usr/kerberos/lib
/usr/X11R6/lib
/usr/lib/qt-2.3.0/lib
/opt/sybase-11.9.2/lib
/usr/java/jdk1.3.1_06/jre/lib/i386/hotspot
/usr/java/jdk1.3.1_06/jre/lib/i386/native_threads
/usr/java/jdk1.3.1_06/jre/lib/i386

My php.ini content about java:
[Java]
java.class.path = /usr/local/src/php-3.3.3/ext/java/php_java.jar:/usr/local/jakarta-tomcat-4.1.24/server/lib/ovjavasvr.jar
java.home = /usr/java/jdk1.3.1_06
java.library =  /usr/java/jdk1.3.1_06/jre/lib/i386/hotspot/libjvm.so
extension_dir = /usr/local/src/php-4.3.3/modules
extension = libphp_java.so

[Java]
java.class.path = /usr/local/src/php-4.3.3/ext/java/php_java.jar:/usr/local/jakarta-tomcat-4.1.24/server/lib/ovjavasvr.jar

java.home = /usr/java/jdk1.3.1_06
java.library.path = /usr/java/jdk1.3.1_06/jre/lib/i386
java.library = /usr/java/jdk1.3.1_06/jre/lib/i386/libjava.so
extension_dir = /usr/local/src/php-4.3.3/modules
extension = libphp_java.so


Where shall i do ? Is is a  new bug ?
Thanks someone to reply it .


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-07 11:03 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

And don't bother adding more comments anywhere either.
We know it doesn't work. 

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 16:03:35 2021 UTC