php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25357 Mail() function is loosing cahracters when sending mail
Submitted: 2003-09-02 06:32 UTC Modified: 2003-09-02 09:37 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: pjsmith at microtech dot co dot gg Assigned:
Status: Not a bug Package: *Mail Related
PHP Version: 4.3.3 OS: Windows 2003, IIS, ISAPI
Private report: No CVE-ID:
 [2003-09-02 06:32 UTC] pjsmith at microtech dot co dot gg
Description:
------------
If you try to mail a string such as 

recur-bill:
notes:
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (MingW32)
Comment: For info see http://www.gnupg.org

iQCVAwUBP1R7lxOu+5gqBlaxAQHHqgQAqPNOlWVQWak4SQ6XUyIBu3c+09EE08lH
MR8mlRGzxy6LZd8MFxmnVjSMyDQJMDWlNwfRFdIokKTI0zDV2IU74GAct9VyPF5D
gW+cGXh7xyLdDBrq5BvjRlZ4iLspdgm1WHyZACV/DNikYTiax+XjYG34rCiN20Bn
3fqcGVXaGFM=
=syYY
-----END PGP SIGNATURE-----

With a pgp signature, it seems to be missing 1 character of the first line of the signature, breaking it.  This worked flawslessly with 4.3.2.  When we upgraded yesterday, this started happening.  I've spent several hours on this and it would appear that the mail() function is at fault.

Reproduce code:
---------------
Mail a pgp signed sig such as in the desciption and check the sig before and after sending.  My messages are about 1,220 bytes in length on average with the sig at the bottom

The code I'm usnig is
				$apptext=fread($domapp,filesize("uk_apps\\$appname". "_modify.asc"));
						fclose($domapp);
						mail("$recipient", "MODIFY", "$apptext",
							"From: <hostmaster@microtech.co.gg>\r\nMessage-Id: <" . time() . "@microtech.co.gg>\r\nReply-To: <hostmaster@microtech.co.gg>\r\nX-Mailer: PHP/" . phpversion());	


Expected result:
----------------
It to send the mail with the string as supplied.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-02 08:19 UTC] pjsmith at microtech dot co dot gg
Just to confirm I have re-installed php 4.3.2 and the problem has gone away...
 [2003-09-02 09:37 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See bug #25333

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 14:02:33 2014 UTC