php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25355 base64_decode returns 0
Submitted: 2003-09-02 06:12 UTC Modified: 2003-09-02 09:41 UTC
From: sadun at isikun dot edu dot tr Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4CVS-2003-09-02 (stable) OS: windows server 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sadun at isikun dot edu dot tr
New email:
PHP Version: OS:

 

 [2003-09-02 06:12 UTC] sadun at isikun dot edu dot tr
Description:
------------
working code on 4.3.3 version wont work on php 4.3.4-dev.

code at the bottom, i checked that $attach_content[1] is not empty also with healty base64 encoding.



Reproduce code:
---------------
  if($fp){
    $attach_content = fread($fp,filesize($attachment_file));
    fclose($fp);
    $attach_content = explode("EXPLODE_FROM_HERE",$attach_content);
    $attach_info = explode("~~",$attach_content[0]);
    $content_type = trim($attach_info[0]);
    $content_type = ereg_replace(";", "", $content_type);

    header("Content-transfer-encoding: binary\n");
    header("Content-Disposition: attachment; filename=$HTTP_GET_VARS[name]\n");

    if($attach_info[1]=="base64"){
      echo base64_decode($attach_content[1]);
    }
    if($attach_info[1]=="8bit"){
      echo imap_8bit($attach_content[1]);
    }
    if($attach_info[1]=="quoted-printable"){
      echo stripslashes(quoted_printable_decode($attach_content[1]));
    }
    if(empty($attach_info[1])){
      echo stripslashes($attach_content[1]);
    } 
  }

Expected result:
----------------
binary source will be printed by php so could be downloaded by browser..



Actual result:
--------------
0 bytes

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-02 06:40 UTC] sadun at isikun dot edu dot tr
the main problem is with mail() function. not with base64 sorry.

somehow when i mail attachments with fixed mail function it do not show them but same code shows same mail with send from old version of mail functions...

why PHP become SO buggy now days. every functions has some problems. but thanks for debuggers
 [2003-09-02 09:41 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See bug #25333
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 22 21:05:44 2022 UTC