php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25352 Cannot compile without --disable-cli
Submitted: 2003-09-02 02:16 UTC Modified: 2003-12-01 02:32 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: gluke@php.net Assigned:
Status: Not a bug Package: mnoGoSearch related
PHP Version: 4.3.4-dev OS: FreeBSD
Private report: No CVE-ID: None
 [2003-09-02 02:16 UTC] gluke@php.net
Description:
------------
Bug #25336 reopened.

When compiling fresh PHP-4.3.3 release with mnogosearch on FreeBSD (not from ports) the process is stopped while linking PHP CLI:

./configure --with-apxs=/usr/local/apache/bin/apxs
--with-pgsql=/usr/local/pgsql --with-gd --with-jpeg-dir=/usr/local/lib
--with-png-dir=/usr/local/lib --with-zlib=/usr
--with-xpm-dir=/usr/local/lib --with-freetype-dir=/usr/local/lib
--with-t1lib=/usr/local/lib --enable-gd-native-ttf
--with-mnogosearch=/usr/local/mnogosearch

With the 4.3.3 release I'm getting this error on build:

/bin/sh /usr/home/alan/php-4.3.3/libtool --silent --preserve-dup-deps
--mode=link gcc -export-dynamic -g -O2  -avoid-version -module
-L/usr/local/lib -L/usr/X11R6/lib -L/usr/local/pgsql//lib
-L/usr/local//lib -L/usr/local/mnogosearch/lib -L/usr/local/pgsql/lib  -R
/usr/local/lib -R /usr/X11R6/lib -R /usr/local/pgsql//lib -R
/usr/local//lib -R /usr/local/mnogosearch/lib -R /usr/local/pgsql/lib
ext/zlib/zlib.lo ext/zlib/zlib_fopen_wrapper.lo ext/ctype/ctype.lo
ext/gd/gd.lo ext/gd/gdttf.lo ext/gd/libgd/gd.lo ext/gd/libgd/gd_gd.lo
ext/gd/libgd/gd_gd2.lo ext/gd/libgd/gd_io.lo ext/gd/libgd/gd_io_dp.lo
ext/gd/libgd/gd_io_file.lo ext/gd/libgd/gd_ss.lo ext/gd/libgd/gd_io_ss.lo
ext/gd/libgd/gd_png.lo ext/gd/libgd/gd_jpeg.lo ext/gd/libgd/gdxpm.lo
ext/gd/libgd/gdfontt.lo ext/gd/libgd/gdfonts.lo ext/gd/libgd/gdfontmb.lo
ext/gd/libgd/gdfontl.lo ext/gd/libgd/gdfontg.lo ext/gd/libgd/gdtables.lo
ext/gd/libgd/gdft.lo ext/gd/libgd/gdcache.lo ext/gd/libgd/gdkanji.lo
ext/gd/libgd/wbmp.lo ext/gd/libgd/gd_wbmp.lo ext/gd/libgd/gdhelpers.lo
ext/gd/libgd/gd_topal.lo ext/gd/libgd/gd_gif_in.lo ext/gd/libgd/xbm.lo
ext/mnogosearch/php_mnogo.lo ext/mysql/php_mysql.lo
ext/mysql/libmysql/libmysql.lo ext/mysql/libmysql/errmsg.lo
ext/mysql/libmysql/net.lo ext/mysql/libmysql/violite.lo
ext/mysql/libmysql/password.lo ext/mysql/libmysql/my_init.lo
ext/mysql/libmysql/my_lib.lo ext/mysql/libmysql/my_static.lo
ext/mysql/libmysql/my_malloc.lo ext/mysql/libmysql/my_realloc.lo
ext/mysql/libmysql/my_create.lo ext/mysql/libmysql/my_delete.lo
ext/mysql/libmysql/my_tempnam.lo ext/mysql/libmysql/my_open.lo
ext/mysql/libmysql/mf_casecnv.lo ext/mysql/libmysql/my_read.lo
ext/mysql/libmysql/my_write.lo ext/mysql/libmysql/errors.lo
ext/mysql/libmysql/my_error.lo ext/mysql/libmysql/my_getwd.lo
ext/mysql/libmysql/my_div.lo ext/mysql/libmysql/mf_pack.lo
ext/mysql/libmysql/my_messnc.lo ext/mysql/libmysql/mf_dirname.lo
ext/mysql/libmysql/mf_fn_ext.lo ext/mysql/libmysql/mf_wcomp.lo
ext/mysql/libmysql/typelib.lo ext/mysql/libmysql/safemalloc.lo
ext/mysql/libmysql/my_alloc.lo ext/mysql/libmysql/mf_format.lo
ext/mysql/libmysql/mf_path.lo ext/mysql/libmysql/mf_unixpath.lo
ext/mysql/libmysql/my_fopen.lo ext/mysql/libmysql/mf_loadpath.lo
ext/mysql/libmysql/my_pthread.lo ext/mysql/libmysql/my_thr_init.lo
ext/mysql/libmysql/thr_mutex.lo ext/mysql/libmysql/mulalloc.lo
ext/mysql/libmysql/string.lo ext/mysql/libmysql/default.lo
ext/mysql/libmysql/my_compress.lo ext/mysql/libmysql/array.lo
ext/mysql/libmysql/my_once.lo ext/mysql/libmysql/list.lo
ext/mysql/libmysql/my_net.lo ext/mysql/libmysql/dbug.lo
ext/mysql/libmysql/strmov.lo ext/mysql/libmysql/strxmov.lo
ext/mysql/libmysql/strnmov.lo ext/mysql/libmysql/strmake.lo
ext/mysql/libmysql/strend.lo ext/mysql/libmysql/strfill.lo
ext/mysql/libmysql/is_prefix.lo ext/mysql/libmysql/int2str.lo
ext/mysql/libmysql/str2int.lo ext/mysql/libmysql/strinstr.lo
ext/mysql/libmysql/strcont.lo ext/mysql/libmysql/strcend.lo
ext/mysql/libmysql/bchange.lo ext/mysql/libmysql/bmove.lo
ext/mysql/libmysql/bmove_upp.lo ext/mysql/libmysql/longlong2str.lo
ext/mysql/libmysql/strtoull.lo ext/mysql/libmysql/strtoll.lo
ext/mysql/libmysql/charset.lo ext/mysql/libmysql/ctype.lo
ext/overload/overload.lo ext/pcre/pcrelib/maketables.lo
ext/pcre/pcrelib/get.lo ext/pcre/pcrelib/study.lo ext/pcre/pcrelib/pcre.lo
ext/pcre/php_pcre.lo ext/pgsql/pgsql.lo ext/posix/posix.lo
ext/session/session.lo ext/session/mod_files.lo ext/session/mod_mm.lo
ext/session/mod_user.lo ext/standard/array.lo ext/standard/base64.lo
ext/standard/basic_functions.lo ext/standard/browscap.lo
ext/standard/crc32.lo ext/standard/crypt.lo ext/standard/cyr_convert.lo
ext/standard/datetime.lo ext/standard/dir.lo ext/standard/dl.lo
ext/standard/dns.lo ext/standard/exec.lo ext/standard/file.lo
ext/standard/filestat.lo ext/standard/flock_compat.lo
ext/standard/formatted_print.lo ext/standard/fsock.lo ext/standard/head.lo
ext/standard/html.lo ext/standard/image.lo ext/standard/info.lo
ext/standard/iptc.lo ext/standard/lcg.lo ext/standard/link.lo
ext/standard/mail.lo ext/standard/math.lo ext/standard/md5.lo
ext/standard/metaphone.lo ext/standard/microtime.lo ext/standard/pack.lo
ext/standard/pageinfo.lo ext/standard/parsedate.lo
ext/standard/quot_print.lo ext/standard/rand.lo ext/standard/reg.lo
ext/standard/soundex.lo ext/standard/string.lo ext/standard/scanf.lo
ext/standard/syslog.lo ext/standard/type.lo ext/standard/uniqid.lo
ext/standard/url.lo ext/standard/url_scanner.lo ext/standard/var.lo
ext/standard/versioning.lo ext/standard/assert.lo
ext/standard/strnatcmp.lo ext/standard/levenshtein.lo
ext/standard/incomplete_class.lo ext/standard/url_scanner_ex.lo
ext/standard/ftp_fopen_wrapper.lo ext/standard/http_fopen_wrapper.lo
ext/standard/php_fopen_wrapper.lo ext/standard/credits.lo
ext/standard/css.lo ext/standard/var_unserializer.lo ext/standard/ftok.lo
ext/standard/aggregation.lo ext/standard/sha1.lo
ext/tokenizer/tokenizer.lo ext/xml/xml.lo ext/xml/expat/xmlparse.lo
ext/xml/expat/xmlrole.lo ext/xml/expat/xmltok.lo regex/regcomp.lo
regex/regexec.lo regex/regerror.lo regex/regfree.lo TSRM/TSRM.lo
TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo
main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/safe_mode.lo
main/fopen_wrappers.lo main/alloca.lo main/php_scandir.lo main/php_ini.lo
main/SAPI.lo main/rfc1867.lo main/php_content_types.lo main/strlcpy.lo
main/strlcat.lo main/mergesort.lo main/reentrancy.lo main/php_variables.lo
main/php_ticks.lo main/streams.lo main/network.lo
main/php_open_temporary_file.lo main/php_logos.lo main/output.lo
main/memory_streams.lo main/user_streams.lo Zend/zend_language_parser.lo
Zend/zend_language_scanner.lo Zend/zend_ini_parser.lo
Zend/zend_ini_scanner.lo Zend/zend_alloc.lo Zend/zend_compile.lo
Zend/zend_constants.lo Zend/zend_dynamic_array.lo Zend/zend_execute_API.lo
Zend/zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo
Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo
Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo
Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo
Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo
Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo
Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/getopt.lo
main/internal_functions_cli.lo -lcrypt -lcrypt -lpq -lt1 -lfreetype -lX11
-lXpm -lpng -lz -ljpeg -lz -lm -lcrypt -lpq -lcrypto -lssl -ludmsearch
-lcrypt -lcrypt  -o sapi/cli/php
libtool: link: cannot find the library `'
*** Error code 1

If I do a --disable-cli everything seems fine. Apache2 module compiles and working fine.

As for me it seems like an libtool bug, since if i remove libtool call from command which links PHP cli  then it compiles ok.

I mean the original line is:
/bin/sh /usr/home/alan/php-4.3.3/libtool --silent --preserve-dup-deps
--mode=link gcc [...other gcc swithes...]

I replace it with:
gcc [...other gcc swithes...]

And linking succeeded.

At this time i dont know how to fix this.

To PHP developers: Have you any suggestions ?



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-02 09:48 UTC] sniper@php.net
Thanks for the huge message, it would have been enough to put the last 10 lines of the output.

Try this:

# rm config.cache
# ./configure --disable-all \
--with-apxs=/usr/local/apache/bin/apxs \
--with-mnogosearch=/usr/local/mnogosearch
# make clean && make

(and is this with apache2 or apache1? --with-apxs is not for apache2)

 [2003-09-03 02:02 UTC] gluke@php.net
I added --with-mysql=[path] to the proposed configure line, otherwise mnogosearch api will not compile if mnogosearch was compiled with mysql support. 

But, this does not help, the linking process was stopped while building CLI with the same error.

P.S. i tested this with apxs2 and apache2, but in the past i had this error with the apache too.
 [2003-09-03 06:38 UTC] sniper@php.net
Please set the status correctly when you respond.

And without --with-mnogosearch (and --with-mysql) it compiles fine?

 [2003-09-06 21:07 UTC] sniper@php.net
Please try applying this patch:

  http://www.php.net/~jani/patches/bug25352.patch

And do:

# ./cvsclean && ./buildconf

And then try your original configure.

 [2003-09-08 09:10 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Try the snapshot in about one hour from now.

 [2003-09-09 04:02 UTC] gluke@php.net
I downloaded php4-STABLE-200309090530.
I run

make clean                                               
                                                         
rm -f config.cache                                       
                                                         
CFLAGS=-O2 ./configure --prefix=/usr/local \             
        --with-mysql=/usr/local \                        
        --with-mnogosearch=/opt/mnogo \                  
        --with-config-file-path=/usr/local/etc/apache2 \ 
        --without-pear --enable-memory-limit \           
        --with-apxs2=/usr/local/sbin/apxs                
                                                         
make                                                     

The same error occurs while linking PHP CLI:

[...]
sapi/cli/php_cli.lo sapi/cli/getopt.lo main/internal_functions_cli.lo
 -lcrypt -lcrypt -lmysqlclient -lm -lz -lm -lmysqlclient -lmnogosearch -lmnogoch
arset -lcrypt -lcrypt  -o sapi/cli/php                                          
libtool: link: cannot find the library `'                                       
*** Error code 1                                                                              
Stop in /opt/php/php4-STABLE-200309090530.                                      

 [2003-09-09 10:10 UTC] sniper@php.net
What is the output of "udm-config --libs" for you?
(it should provide the libs needed, so you do NOT need --with-mysql!)
(and AGAIN, set the status to "Open" when you reply!!!!)

 [2003-09-10 02:06 UTC] gluke@php.net
[root@faust root]# /opt/mnogo/bin/udm-config --libs                             
-lz -lm -L/usr/local/lib/mysql -lmysqlclient -L/opt/mnogo/lib -lmnogosearch -lmn
ogocharset                                                                      
[root@faust root]#                                                           

P.S. Remember please that apache module compile and work ok, and removing libtool call make PHP cli compile and work too.   
 [2003-12-01 02:32 UTC] sniper@php.net
It's a libtool bug with invalid .la files, in this case the installed libudmsearch.la file is broken.
Remove that and this should work fine.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 16:01:27 2021 UTC