php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25346 Mail() function crashes PHP.exe
Submitted: 2003-09-01 14:48 UTC Modified: 2003-09-01 17:46 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: leon at hitman dot co dot uk Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.3.3 OS: Win XP/2000
Private report: No CVE-ID:
 [2003-09-01 14:48 UTC] leon at hitman dot co dot uk
Description:
------------
Ran a script that uses the mail function.
The script worked with version 4.2.3 of PHP.
It attempts to attach three files to the multipart/mixed message, but runs for app. 10 secs, then forces PHP.exe the quit.
Like I said, it used to work!

After commenting out the code line-by-line, I determined that the message part of the mail() function was causing the issue.

I would like to know if there hass been a significant change in the requirements of the mail() function to suddenly cause it to crash.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-01 17:46 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See bug #25333 (it might not seem same first, but while trying to reproduce it, php crashed for me. Same issue.)

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 14:02:33 2014 UTC