php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25147 CC=gcc -Werror causes build fail
Submitted: 2003-08-19 08:04 UTC Modified: 2003-08-19 16:42 UTC
From: burlybutler at hotmail dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: Irrelevant OS: *
Private report: No CVE-ID: None
 [2003-08-19 08:04 UTC] burlybutler at hotmail dot com
Description:
------------
It may be obvious to many, but I recently was stuck when compiling php because I'd forgotten my CC setting was gcc -Werror.

Perhaps in your configure script you could check for this (and warn), which would help some inexperienced people?

First I got a warning/error at var_unserializer.c:308 (I think this has been around some time) but then more confusingly it caused the Makefile to be written without -lm (due to a warning in the maths library sin test) causing make to fail, without an obvious cause to the inexperienced!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-19 14:34 UTC] helly@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

We sometimes use this to find warnings that are really errors and on the other hand we can't fix all warnings because not every compiler (in this case especially gcc) doesn't understand every code good enough. For example some compilers don't build up their compiler tree detailed enough to be abel to see all execution paths ...

Therefor any bug related to -Werror is bogus

Besides that we can't hinder you from miscongiguring your system in anyway possible.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 20 07:01:25 2020 UTC