php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25090 Driver initialization failed for handler: db3 - not a permission problem
Submitted: 2003-08-14 01:57 UTC Modified: 2003-08-15 14:33 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: fabio_heller at yahoo dot it Assigned: helly (profile)
Status: Not a bug Package: DBM/DBA related
PHP Version: 4.3.3RC4-dev OS: win 2000 sp3
Private report: No CVE-ID: None
 [2003-08-14 01:57 UTC] fabio_heller at yahoo dot it
Description:
------------
Using mod php 4.3.2 on Apache 1.3.27

phpinfo() says thah supported handlers are cdb, cdb_make, db3, flatfile.

dba extension enabled.

It is not a permission problem as "flatfile" handler works as expected

Reproduce code:
---------------
<?php


$id = dba_open('d:/www_new/xyz.db', 'c', 'db3') ;

dba_replace('fookey', 'foovalue', $id) ;

dba_close($id) ;



?>

Expected result:
----------------
File creation and no driver initialization errors, instead only 'flatfile' works as expected

Actual result:
--------------
-------------
Warning: dba_open(d:/www_new/xyz.db,c): Driver initialization failed for handler: db3: Permission denied in d:\www_new\sqlite\dba.php on line 5

Warning: dba_replace(): supplied argument is not a valid DBA identifier resource in d:\www_new\sqlite\dba.php on line 7

Warning: dba_close(): supplied argument is not a valid DBA identifier resource in d:\www_new\sqlite\dba.php on line 9
-----------------

Anyway *** file is created *** in spite of errors


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-14 04:26 UTC] fabio_heller at yahoo dot it
Same problem with snapshot version unfortunately
 [2003-08-15 08:50 UTC] sniper@php.net
Isn't this same bug as #23975 ?
 [2003-08-15 14:33 UTC] helly@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

Duplicate of #23975 
Use 'l' or '-' modifier on open.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Mar 21 05:01:26 2019 UTC