php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25078 conflict between libiconv and recode
Submitted: 2003-08-13 12:26 UTC Modified: 2003-08-13 15:50 UTC
From: admin at the66 dot org Assigned:
Status: Not a bug Package: CGI/CLI related
PHP Version: 4.3.3RC3 OS: Redhat 7.2
Private report: No CVE-ID: None
 [2003-08-13 12:26 UTC] admin at the66 dot org
Description:
------------
when compiling with libiconv-1.9.1 and recode-3.6 support, cli version uses recode's bundled libiconv-1.5 instead of library provided through configure
this results in failure of ext/iconv/tests/translit-failure.phpt


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-13 12:45 UTC] moriyoshi@php.net
You can avoid it by using glibc iconv instead of libiconv as long as you have working glibc installed in your linux box.

Anyway that's a recode problem, not our issue though.
 [2003-08-13 15:50 UTC] admin at the66 dot org
but why do both extensions work together under apache and not as cli?
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC