php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25053 seg fault
Submitted: 2003-08-12 07:48 UTC Modified: 2003-09-12 05:51 UTC
From: kevin at oceania dot net Assigned: abies (profile)
Status: Not a bug Package: InterBase related
PHP Version: 4CVS-2003-08-12 (stable) OS: linux
Private report: No CVE-ID: None
 [2003-08-12 07:48 UTC] kevin at oceania dot net
Description:
------------
'./configure' '--host=i386-redhat-linux' '--build=i386-redhat-linux' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--with-apxs2=/usr/local/apache/bin/apxs' '--enable-pic' '--disable-rpath' '--enable-inline-optimization' '--prefix=/usr/local/apache/php' '--with-config-file-path=/usr/local/apache/php' '--enable-track-vars' '--enable-force-cgi-redirect' '--disable-cgi' '--with-gettext' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-gd' '--enable-gd-native-ttf' '--enable-gd-jis-conv' '--with-ttf' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--enable-bcmath' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-discard-path' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--without-oci8' '--with-pear=/usr/share/pear' '--with-mysql=/usr' '--with-sqlite' '--enable-memory-limit' '--enable-shmop' '--enable-versioning' '--enable-calendar' '--enable-dio' '--enable-mcal' '--with-pspell' '--with-png' '--with-png-dir=/usr' '--with-xsl' '--with-domxml' '--with-dom5' '--with-qtdom' '--with-zlib' '--with-xslt-sablot=/usr' '--with-sablot-js=/usr' '--with-expat-dir=/usr' '--with-gdbm' '--enable-dbx' '--with-imap=shared' '--with-imap-ssl' '--with-openssl' '--with-kerberos=/usr/kerberos' '--with-layout=GNU' '--with-tiff=/usr' '--with-curlwrappers' '--with-filepro' '--with-xpm-dir=/usr' '--with-libxml-dir=/usr' '--with-xmlrpc' '--with-simplexml' '--with-debug' '--with-interbase=/usr/local/firebird'


When using ibase_query() an error occurs when calling
first from inside a class then calling ibase_query()
from outside the class. ie, in the class calling
$this->method() and then doing something like
$obj=new classname; $obj->method()

Reproduce code:
---------------
index.phps
phoenix.phps
browse.phps

Expected result:
----------------
would be nice if it worked, or gave an error message.

Actual result:
--------------
[Tue Aug 12 23:46:31 2003] [notice] child pid 2639 exit signal Segmentation fault (11)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-12 22:18 UTC] kevin at oceania dot net
url for single file that causes seg fault

http://203.109.184.88/phoenix/segfault.phps
 [2003-08-13 07:05 UTC] abies@php.net
We really need a back trace, because I cannot reproduce the error by running the code you sent. 
 [2003-08-16 18:27 UTC] abies@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

I suspect the reason for the segfault is the same as for bug #7014 (among others). The segfault will prevent you from seeing what the actual error is. This has been corrected in more recent CVS versions of PHP4
 [2003-08-17 02:58 UTC] kevin at oceania dot net
installed php4-STABLE-200308170330
segfault still persists
 [2003-08-17 05:37 UTC] sniper@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2003-08-21 00:01 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-09-12 05:51 UTC] abies@php.net
Never been able to reproduce this, no feedback for a month ...
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri May 29 17:01:40 2020 UTC