php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25005 php can not compile --with-oracle
Submitted: 2003-08-10 15:42 UTC Modified: 2003-08-11 14:31 UTC
From: phpnet at gal dot dk Assigned:
Status: Closed Package: Oracle related
PHP Version: 4.3.3RC3 OS: FreeBSD 4.8-STABLE
Private report: No CVE-ID: None
 [2003-08-10 15:42 UTC] phpnet at gal dot dk
Description:
------------
To compile php --with-oracle support, you have to install Oracle7 libraries on FreeBSD. This is done automatically from the ports-system.. However with 4.3.3RC2 I can no longer get this to compile. With 4.3.2 it works perfect.



Reproduce code:
---------------
The FreeBSD ports system generates this file after what I choose in the pseudo-graphic menu-thing that helps me pick out php features.

WITH_CTYPE=yes
WITH_MYSQL=yes
WITH_ORACLE=yes
WITH_OVERLOAD=yes
WITH_PCRE=yes
WITH_POSIX=yes
WITH_SESSION=yes
WITH_TOKENIZER=yes
WITH_XML=yes
WITH_ZLIB=yes

I can leave just about anything out, except the WITH_ORACLE setting, and the compile still fails.

Actual result:
--------------
/usr/local/oracle7/lib/libclient.a(upigem.o): In function 'upilem':
upigem.o(.text+0x454): undefined reference to '__wrap_sprintf'
upigem.o(.text+0x48e): undefined reference to '__wrap_sprintf'
/usr/local/oracle7/lib/lbibclient.a(upilog.o): In function ' upilgn':
upigem.o(.text+0x1136): undefined reference to __wrap_sprintf'
..
..
.. And then a million more just like them. All complaining aboyt undefined references to __wrap-functions.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-10 21:43 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

And please use the command line ./configure...
If the snapshot fails, provide the full configure line you have used.

 [2003-08-11 09:50 UTC] phpnet at gal dot dk
./configure --with-oracle=/usr/local/oracle7

Same error with php4-STABLE-200308111330.

Please be advised that the ./configure line could only be successfully completed with the patches for 4.3.3RC2 (within the ports collection) applied to the configure script. Otherwise the configure script doesn't acknowledge the Oracle7 libraries.
 [2003-08-11 09:55 UTC] phpnet at gal dot dk
The patch for the configure script can be inspected here:

http://www.freebsd.org/cgi/cvsweb.cgi/ports/lang/php4/files/patch-configure

If necessary.
 [2003-08-11 12:01 UTC] sniper@php.net
Do NOT patch the configure (we don't support patched stuff, only clean sources) and tell us WHAT the real problem is.
We don't do these 'ports', maybe you should be reporting this to those people who are responsible for those?


 [2003-08-11 14:31 UTC] phpnet at gal dot dk
I didn't suspect the configure script, since the problem arises during the compile phase, and the patch merely helps to identify which Oracle version is installed.

I notified the maintainer of the php-port for FreeBSD.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 27 14:03:37 2021 UTC