php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24982 PHP can't run as a CGI
Submitted: 2003-08-08 03:36 UTC Modified: 2003-08-08 03:51 UTC
From: peters at stack dot nl Assigned:
Status: Not a bug Package: CGI/CLI related
PHP Version: 4.3.3RC3 OS: gnu/linux
Private report: No CVE-ID: None
 [2003-08-08 03:36 UTC] peters at stack dot nl
Description:
------------
PHP runs as a CGI under the webserver and produces an error.
Reproducable with these commands (commandline):

peter@xaron:~/public_html% REQUEST_METHOD=GET PATH_INFO=/ PATH_TRANSLATED="/home/peter/public_html/index.php" php

Which results in:

Status: 404
Content-type: text/html
X-Powered-By: PHP/4.3.3RC3

No input file specified.


Reproduce code:
---------------
At shell-prompt:

REQUEST_METHOD=GET PATH_INFO=/ PATH_TRANSLATED="/home/peter/public_html/index.php" php

Expected result:
----------------
I expect the file index.php (which does exist) to be processed.

Actual result:
--------------
Status: 404
Content-type: text/html
X-Powered-By: PHP/4.3.3RC3

No input file specified.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-08 03:51 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Works fine for me, you just have installed it wrong.

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC