php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24853 General extensions load fails for undefined symbols
Submitted: 2003-07-29 08:53 UTC Modified: 2003-07-29 10:51 UTC
From: alietss at yahoo dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4CVS-2003-07-29 (stable) OS: Linux RedHat 9.0
Private report: No CVE-ID:
 [2003-07-29 08:53 UTC] alietss at yahoo dot com
Description:
------------
Hi people:
I'm testing php-4.3.3 on RedHat 9.0 with httpd-2.0.47-3 added unixd.h and related headers files and used redhat patches to prevent the load of extensions when exists undefined symbols, I built php as a handler, when I start apache the extensions fails to load with this errors on apache error log...

PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/imap.so' - /usr/lib/php4/imap.so: undefined symbol: file_globals in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/ldap.so' - /usr/lib/php4/ldap.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mcal.so' - /usr/lib/php4/mcal.so: undefined symbol: convert_to_array in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mcrypt.so' - /usr/lib/php4/mcrypt.so: undefined symbol: OnUpdateString in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mhash.so' - /usr/lib/php4/mhash.so: undefined symbol: zend_register_long_constant in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mssql.so' - /usr/lib/php4/mssql.so: undefined symbol: OnUpdateBool in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mysql.so' - /usr/lib/php4/mysql.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/odbc.so' - /usr/lib/php4/odbc.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/pdf.so' - /usr/lib/php4/pdf.so: undefined symbol: core_globals in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/pgsql.so' - /usr/lib/php4/pgsql.so: undefined symbol: OnUpdateBool in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/snmp.so' - /usr/lib/php4/snmp.so: undefined symbol: zend_get_parameters_ex in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/xslt.so' - /usr/lib/php4/xslt.so: undefined symbol: executor_globals in Unknown on line 0

Here my configure line....

'./configure' '--host=i686-pc-linux-gnu' '--build=i686-pc-linux-gnu' '--target=i686-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--enable-force-cgi-redirect' '--disable-debug' '--enable-pic' '--disable-rpath' '--enable-inline-optimization' '--with-bz2' '--with-db4=/usr' '--with-curl' '--with-dom=/usr' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-gd' '--enable-gd-native-ttf' '--with-ttf' '--with-gdbm' '--with-gettext' '--with-pdflib=shared' '--with-tiff-dir=/usr' '--with-ncurses' '--with-gmp' '--with-iconv' '--enable-xslt=shared' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-regex=system' '--with-xml' '--with-xmlrpc' '--with-expat-dir=/usr' '--with-zlib' '--with-layout=GNU' '--enable-bcmath' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-discard-path' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--without-oci8' '--with-pear=/usr/share/pear' '--with-imap=shared' '--with-imap-ssl' '--with-kerberos=/usr/kerberos' '--with-ldap=shared' '--with-mcal=shared,/usr' '--with-mcrypt=shared,/usr' '--with-mhash=shared,/usr' '--with-mssql=shared,/usr' '--with-mysql=shared,/usr' '--with-pgsql=shared' '--with-snmp=shared,/usr' '--with-snmp=shared' '--enable-ucd-snmp-hack' '--with-xslt-sablot=shared,/usr' '--with-sablot-js=shared,/usr' '--with-unixODBC=shared' '--enable-memory-limit' '--enable-bcmath' '--enable-shmop' '--enable-versioning' '--enable-calendar' '--enable-dbx' '--enable-dio' '--enable-mcal' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-apxs2=/usr/sbin/apxs'

                                 Any ideas??


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-29 09:09 UTC] iliaa@php.net
What process model are you using with your apache?
 [2003-07-29 10:51 UTC] sniper@php.net
you are using unofficial patches to PHP? Not our prob.
Also, you use certain configure options that you should not use, like --enable-versioning, --with-regex=system..

Try with this configure line: ./configure --disable-all --with-apxs2...and only ONE shared extension.

This works fine for me, no bug.



 [2003-09-07 18:42 UTC] jorton at redhat dot com
This bug was due to use of the --enable-versioning flag, which is in principle not compatible with using loadable modules.  In practice it works with libtool 1.4 and earlier, since those versions don't implement the -export-symbols flag correctly.

Upgrade to libtool 1.5 and -export-symbols does what you tell it, and PHP can't load modules any more.

This bug is in no way specific to the apache2handler or filter; it would affect the apache 1.3 SAPI module as well, or any SAPI which is built as a DSO on Unix.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 00:02:04 2014 UTC