php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #24702 disable_functions + httpd.conf should not set value
Submitted: 2003-07-18 03:24 UTC Modified: 2017-01-08 06:27 UTC
Votes:4
Avg. Score:4.0 ± 0.7
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:3 (100.0%)
From: philip at cornado dot com Assigned: krakjoe (profile)
Status: Closed Package: *General Issues
PHP Version: 4.3.3RC1 OS: linux
Private report: No CVE-ID: None
 [2003-07-18 03:24 UTC] philip at cornado dot com
Description:
------------
As we all know, setting disable_functions and disable_classes is not possible in httpd.conf as they are special case PHP_INI_SYSTEM directives, but doing so still emits a local value even knowing it has no meaning.  In otherwords, setting disable_* in httpd.conf should not affect the local ini value as it does currently.

Note: As expected, setting via ini_set() or .htaccess does not affect the value.

Reproduce code:
---------------
In httpd.conf:
php_admin_value disable_functions "mail"

PHP:
echo ini_get('disable_functions');


Expected result:
----------------
no value

Actual result:
--------------
mail

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-03 07:27 UTC] anonymous at internet dot com
same problem in version 4.3.4 (final).
 [2013-08-03 15:54 UTC] ben dot rubson at gmail dot com
See summary bug #65386
 [2017-01-08 06:27 UTC] krakjoe@php.net
-Status: Open +Status: Closed -Package: Feature/Change Request +Package: *General Issues -Assigned To: +Assigned To: krakjoe
 [2017-01-08 06:27 UTC] krakjoe@php.net
Since this concerns an ancient version of PHP, and since this has never generated a decent conversation, there is obviously no appetite for this change.

Closing.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed May 27 00:01:25 2020 UTC