php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24684 PHP 4.3.1 + no longer compatible with O'reilly WebSite Pro 3.0
Submitted: 2003-07-16 14:44 UTC Modified: 2003-07-17 12:32 UTC
From: webmaster at wisesoftwareinc dot com Assigned:
Status: Not a bug Package: CGI/CLI related
PHP Version: 4.3.1 OS: Win 2000 SP4
Private report: No CVE-ID: None
 [2003-07-16 14:44 UTC] webmaster at wisesoftwareinc dot com
Description:
------------
Greetings, PHP

I have spent the last few days trying to find a successful combination that will work with O'reilly WebSite 3.0 as well as PHP 4.3.0 does. 

Versions 4.3.1 and higher (including 5 beta) seems to be no longer compatible with this web server software.

I use the CGI configuration w/o cgi redirect on two other identical severs - which works seamlessly with PHP 4.3.0 and O'reilly WebSite 3.0.

After failed attempts with versions 4.3.1+ on this new server, I tried this same PHP 4.3.0 configuration and again works perfectly.

But now with 4.3.1 + all I receive is the "No Input File Specified" messages or page not found is some cases.

I'm only presenting the 3 notes below to prove incompatibility... please do not take them as support questions or a false bugs reports; I do realize they would be if submitted separately as such.

Solutions Tried for 4.3.1 +

1. I tried the CLI folder's php.exe, which works past the default php.exe only to the point were the simplest echo of "hello world" needs to have a line break before any PHP or html code - or you receive a CGI 500 error.

2. So I place a line break before any code to get the script to output properly - but of course I then can not use sessions. (headers already sent message).

3. I then tried the isapi extension configuration - which too does not work with sessions on WebSite Pro 3 - due to the fact that the session_start function creates a new session file on every page refresh.



This new lack of compatibility may or may not be a bug, but I feel it needs to be professionally addressed by the PHP staff. Even a notice on the web site, though heart breaking, would suffice.

Thank you for your kind attention.

Reproduce code:
---------------
<html>
<head>
<title>test</title>
</head>
<body>
<?PHP
echo 'hello world';
?>
</body>
</html>

Expected result:
----------------
Hello World

Actual result:
--------------
: : : : : hello world : : Content-length: 589 
500 Server Error
The server encountered an error and was unable to complete your request.
Message: CGI output from C:/WebSite/htdocs/test.php contained no blank line separating header and data (most likely a broken CGI program)

Please contact the server administrator at webmaster@wisesoftwareinc.com and inform them of the time the error occured, plus anything you know of that may have caused the error.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-16 15:12 UTC] edink@php.net
Try latest stable snapshot from http://snaps.php.net/

Then try setting cgi.fix_pathinfo in your php.ini file. I don't know which setting (0 or 1) works with that webserver, but one of them should.

 [2003-07-16 16:31 UTC] webmaster at wisesoftwareinc dot com
Greetings, 

Thank you very much for your expedient response, it is greatly appreciated.

I downloaded and installed the latest snap shot and switched between 1 and 0 on the cgi.fix_pathinfo setting as you suggested, but alas the problem (bug?) still remains with the 4.3.2 snap shot on WebSite Pro 3.
 [2003-07-16 20:53 UTC] sniper@php.net
DO NOT use the 'Add comment' link when you add comments to your own bug report, use the 'Edit Submission'..

And this is bogus, CLI is not CGI.

 [2003-07-17 11:21 UTC] webmaster at wisesoftwareinc dot com
Greetings, 

I've tried three different ways to get PHP 4.3.1 + to run on server software that works fine with 4.3.0 - CLI is just one thing I tried as specified in my "bogus" bug report. I do understand the difference.

You changed something in 4.3.1. 

What happened, at least tell us that and I'll leave this issue alone and stick with 4.3.0.

Thank you.
 [2003-07-17 12:32 UTC] webmaster at wisesoftwareinc dot com
Greetings, 

Let me clarify this.

The only successful combination that WebSite Pro 3 has with PHP 4.3.0 and lower is the following:

You must use the php.exe (the default one, not CLI's folder of php.exe of course).
You must set wwwserver/shellcgi as the content type.
You must set "cgi.force_redirect = 0"

This has successfully worked on three servers using WSP 3 since PHP 4 was on the table until 4.3.1.

I only tried the other configuration I mentioned, in my past correspondence on this issue, out of desperation not as a final solution.

Sorry if I'm being a pest, but something changed.

I just want you to know that I'm too much in love with PHP to disrespect you guys.

Thank you for time and kind help!

Best wishes!
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC