php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24672 "parse" is not similar to "parse_ini_file"
Submitted: 2003-07-16 02:51 UTC Modified: 2003-08-07 13:16 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: goba@php.net Assigned: goba (profile)
Status: Wont fix Package: Website problem
PHP Version: 4.3.2 OS: irrelevant
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-07-16 02:51 UTC] goba@php.net
Description:
------------
When using the PHP.net document search function on de3.php.net to search for parse_ini_file() and using the searchstring
"parse " (note the trailing space) this function will be found, but not on de.php.net and de2.php.net.
Searching for "parse" only does not even return the parse_ini_file function. There seems to be a problem with double underscores in function names and the website search.


Reproduce code:
---------------
Try to search for "parse" on any of the de.php.net mirrors and  see yourself what is returned ;)

Expected result:
----------------
Expected to get a list of functions containing the word "parse", but not all functions are returned, mainly none of the functions containing double underscores.

Actual result:
--------------
As mentioned above, this is always reproduceable with either Mozilla 1.4 or IE 6.0.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-17 04:03 UTC] goba@php.net
There are functions returned with double underscores, when searching for "parse" or "parse " (without quotes). Namely yaz_ccl_parse and mb_parse_str. The fact that the parse_ini_file function is not found is probably a bug in the similar_text() function, which we use on the website.
 [2003-07-19 12:28 UTC] sniper@php.net
1. Where is the reproducing short script?
2. What PHP versions are affected? (CVS)

 [2003-07-20 08:53 UTC] goba@php.net
I'll go into this more deeply. I have just made some test cases, showing interesting results (that the bug is probably not in PHP, but in the website code :). Therefore I am categorizing this stuff back to a website problem, and assigning it to myself. Sorry for bothering.
 [2003-07-20 08:58 UTC] goba@php.net
BTW I am not the original submitter of this bug report, don't know how I came to be in the database, I have just modified some data of the report (summary, OS, category), while commenting on it.
 [2003-08-07 13:16 UTC] goba@php.net
The original problem is not solved, but the number of listed results is extended.

The real issue here is that if we have very long function names, one small part is not enough to make the long name similar, so "less similar" functions come up to have better listings in this algorithm...

As this is not a bug in the website code, we are not going to fix it...
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Mar 20 21:01:26 2019 UTC