php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24614 php as cgi always report 'No input file specified.'
Submitted: 2003-07-11 19:10 UTC Modified: 2003-07-12 18:10 UTC
From: deptotecnico at towebs dot com Assigned:
Status: Not a bug Package: CGI/CLI related
PHP Version: 4.3.3RC1 OS: Linux
Private report: No CVE-ID: None
 [2003-07-11 19:10 UTC] deptotecnico at towebs dot com
Description:
------------
  
  If I compile php as cgi (--enable-force-cgi-redirect is not used), I always get 'No input file specified' while browsing any .php file.
  I've tried with 4.3.1, 4.3.2 and 4.3.3RC1, with php.ini-recommended as the init file. 
  php -v gives:

PHP 4.3.3RC1 (cgi) (built: Jul 11 2003 20:52:32)
Copyright (c) 1997-2003 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies

  running the same code from console (path/to/php/cgi file.php) works fine. 
  I've been looking around and I've seen several old reports for this and a few ones, but no fixed whatsoever.
  I've also checked the CVS repository, but doesn't seem like anything has changed wrt in cgi_main.c.




Reproduce code:
---------------
<?
phpinfo ();
?>

Expected result:
----------------
phpinfo() output.

Actual result:
--------------
No input file specified.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-12 00:44 UTC] deptotecnico at towebs dot com
of course, this should be read as:

 .. looking around and I've seen several old reports for and a few new ones, but no fixed whatsoever.
 [2003-07-12 03:22 UTC] deptotecnico at towebs dot com
after further investigation and debugging, setting doc_root in php.ini fixed the issue. my apologies.
 [2003-07-12 08:17 UTC] sniper@php.net
..
 [2003-07-12 11:34 UTC] deptotecnico at towebs dot com
sigh. what really fixed the problem was adding --enable-discard-path.
 [2003-07-12 18:10 UTC] sniper@php.net
Whatever, it's still user error. Please don't touch this anymore.

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC