php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #24590 True FastCGI support
Submitted: 2003-07-10 10:19 UTC Modified: 2015-01-08 22:37 UTC
Votes:8
Avg. Score:5.0 ± 0.0
Reproduced:8 of 8 (100.0%)
Same Version:6 (75.0%)
Same OS:6 (75.0%)
From: james at grickel dot org Assigned:
Status: Wont fix Package: CGI/CLI related
PHP Version: * OS: *
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-07-10 10:19 UTC] james at grickel dot org
Description:
------------
Currently PHP's FastCGI's code just keeps php loaded while the script is executed over and over every time.

I'm proposing a system where fastcgi could be natively used by the php script. Like how fastcgi is used in perl, or C.

The code could possibly look something like this:
------------------
#!/usr/bin/php-fastcgi
<?php
do_init();
while(fastcgi_next_request() != null) {
    do_request_stuff();
}
do_shutdown();
?>
------------------

This would allow large scripts that load lots of data to keep them loaded and serve many requests.

This would be very advantagous for performance. The script itself would look like a fastcgi script to the server. Not the php executable. So you wouldn't be able to use the apache Action directive. You'd just need to have the hash-bang in every php file.

I'm not familiar enough with php's sapi, nor fastcgi. But from what I know it should be possible if you don't use treat the php _script_ as a cgi and use the hash-bang on every file.

Thanks,
James Harr


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-09 15:23 UTC] dpenning at s0nix dot de
imho this should be implemented as an php-extension.
then the user would have to run the script via php-cli
 [2003-12-09 01:31 UTC] james at grickel dot org
Would it be possible to implement this easily through an extension? It'd probably be a good idea to work on this in PHP5 since PHP5 is almost out and it woudl be easier to integrate.

Who's interested in this?
 [2010-11-18 23:12 UTC] jani@php.net
-Package: Feature/Change Request +Package: CGI related -Operating System: +Operating System: * -PHP Version: Irrelevant +PHP Version: *
 [2015-01-08 22:37 UTC] ajf@php.net
-Status: Open +Status: Wont fix
 [2015-01-08 22:37 UTC] ajf@php.net
PHP's shared-nothing architecture isn't going to change any time soon.

If you want performance, use an opcache.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Apr 26 08:01:25 2019 UTC