php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24532 Can't configure fir LDAP
Submitted: 2003-07-08 03:53 UTC Modified: 2003-07-08 09:55 UTC
From: mkj dot its at cbs dot dk Assigned:
Status: Closed Package: LDAP related
PHP Version: 5.0.0b1 (beta1) OS: RedHat 9
Private report: No CVE-ID: None
 [2003-07-08 03:53 UTC] mkj dot its at cbs dot dk
Description:
------------
When configure with LDAP support it fails, with:

Im using:

RedHat 9
OpenLDAP 2.1.22

The CVS version of PHP 5 (taken from snaps.php.net) was working fine with my setup. But the Beta don't.

checking for LDAP support... yes, shared
checking for LDAP Cyrus SASL support... /usr
checking for 3 arg ldap_set_rebind_proc... yes
checking for ldap_parse_reference... no
checking for ldap_start_tls_s... no
checking for sasl_version in -lldap... yes
checking for ldap_bind_s... no
configure: error: LDAP build check failed. Please check config.log for more information.
error: Bad exit status from /var/tmp/rpm-tmp.47994 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.47994 (%build)


Reproduce code:
---------------
configure:41658: checking for ldap_bind_s
configure:41686: gcc -o conftest -g -O2 -I/usr/kerberos/include -L/usr/lib -ldb-4.1  conftest.c -lcrypt -lpam -lgd -lfreetype -lpng -lz -ljpeg -ldb-4.1 -lgdbm -lbz2 -lz -lssl -lcrypto -lresolv -lm -ldl -lnsl  1>&5
/tmp/cc08qEfy.o(.text+0xa): In function `main':
/home/mkj/rpm/BUILD/php-5.0.0b1/configure:41680: undefined reference to `ldap_bind_s'
collect2: ld returned 1 exit status
configure: failed program was:
#line 41663 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char ldap_bind_s(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char ldap_bind_s();
 
int main() {
 
/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_ldap_bind_s) || defined (__stub___ldap_bind_s)
choke me
#else
ldap_bind_s();
#endif
                                                                                                    
; return 0; }



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-08 09:55 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Oct 07 22:05:53 2022 UTC