php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24508 Different result of round()
Submitted: 2003-07-05 16:00 UTC Modified: 2005-09-22 21:41 UTC
Votes:2
Avg. Score:3.5 ± 0.5
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: erlendkb at online dot no Assigned: edink (profile)
Status: Closed Package: Math related
PHP Version: 5.0.0b1 (beta1) OS: Windows XP
Private report: No CVE-ID: None
 [2003-07-05 16:00 UTC] erlendkb at online dot no
Description:
------------
This script gives different results in PHP4 (PHP 4.3.2) og PHP5 (5.0.0 BETA 1)

Reproduce code:
---------------
<?php

$end =   date ("U", mktime (11, 00, 0, 7, 4, 2003));
$start = date ("U", mktime (8, 35, 0, 1, 11, 2003));

$hanne = $end - $start;

echo round ($hanne/3600, 2);

?>

Expected result:
----------------
PHP4:
4177.42

PHP5:
4177.41

Actual result:
--------------
...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-07 10:17 UTC] sniper@php.net
This is due to some funky build problem Edin has..
Assigning to him so he won't forget about it. :)

 [2003-07-28 17:07 UTC] edink@php.net
Fixed in the latest snaps from snaps.php.net.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Nov 26 23:05:53 2022 UTC