php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2442 Apache 1.3.9 segfaults (sig11) when PHP documents are called
Submitted: 1999-10-04 22:29 UTC Modified: 2002-06-16 08:58 UTC
From: gashalot at gashalot dot com Assigned:
Status: Not a bug Package: Reproducible Crash
PHP Version: 3.0.12 OS: FreeBSD 3.3-STABLE
Private report: No CVE-ID: None
 [1999-10-04 22:29 UTC] gashalot at gashalot dot com
[Tue Oct  5 02:18:10 1999] [notice] Apache/1.3.9 (Unix) PHP/3.0.12 mod_perl/1.21 mod_frontpage/3.0.4.3 mod_ssl/2.4.5 OpenSSL/0.9.4 configured -- resuming normal operations
[Tue Oct  5 02:18:14 1999] [notice] child pid 88941 exit signal Segmentation fault (11)

I have seen a similar bug under RedHat 6 I believe, and it appears that he is also running fp and mod_ssl, don't know any connection here.  Was working fine before, and now it appears to be having major problems (well, all PHP3 pages cause it to dump).  I am not sure what would be causing this.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-10-04 22:54 UTC] gashalot at gashalot dot com
UNAME OUTPUT--------------------
FreeBSD websvr1.mn1.fasturl.net 3.3-STABLE FreeBSD 3.3-STABLE #3: Sun Sep 26 20:06:38 GMT 1999     gashalot@websvr1.mn1.fasturl.net:/usr/src/sys/compile/WEBSVR1  i386

dmesg KERN OUTPUT-------FreeBSD 3.3-STABLE #3: Sun Sep 26 20:06:38 GMT 1999
    gashalot@websvr1.mn1.fasturl.net:/usr/src/sys/compile/WEBSVR1
Timecounter "i8254"  frequency 1193182 Hz
CPU: Pentium III (686-class CPU)
  Origin = "GenuineIntel"  Id = 0x673  Stepping = 3
  Features=0x383fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CM
OV,PAT,PSE36,MMX,FXSR,<b25>>
real memory  = 536870912 (524288K bytes)
avail memory = 519655424 (507476K bytes)
Programming 24 pins in IOAPIC #0
FreeBSD/SMP: Multiprocessor motherboard
 cpu0 (BSP): apic id:  1, version: 0x00040011, at 0xfee00000
 cpu1 (AP):  apic id:  0, version: 0x00040011, at 0xfee00000
 io0 (APIC): apic id:  2, version: 0x00170011, at 0xfec00000
Preloaded elf kernel "kernel" at 0xc029d000.
Pentium Pro MTRR support enabled

----------


EXTENDED HTTP INFO------------------
bash-2.03# ./httpd -V    
Server version: Apache/1.3.9 (Unix)
Server built:   Oct  2 1999 00:56:50
Server's Module Magic Number: 19990320:6
Server compiled with....
 -D EAPI
 -D HAVE_MMAP
 -D USE_MMAP_SCOREBOARD
 -D USE_MMAP_FILES
 -D USE_FLOCK_SERIALIZED_ACCEPT
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D HTTPD_ROOT="/usr/local/apache"
 -D SUEXEC_BIN="/usr/local/apache/bin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/httpd.scoreboard"
 -D DEFAULT_LOCKFILE="logs/httpd.lock"
 -D DEFAULT_XFERLOG="logs/access_log"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"
 -D ACCESS_CONFIG_FILE="conf/access.conf"
 -D RESOURCE_CONFIG_FILE="conf/srm.conf"


GDB OUTPUT (NO CORE FILES WOULD GENERATE)----------------------
(gdb) run -X
Starting program: /usr/local/apache/bin/./httpd -X

Program received signal SIGSEGV, Segmentation fault.
0x80a3407 in _estrdup (s=0x0) at alloc.c:267
267             length = strlen(s)+1;
(gdb) bt
#0  0x80a3407 in _estrdup (s=0x0) at alloc.c:267
#1  0x80a5207 in php3_init_request_info (conf=0x820ea88) at request_info.c:210
#2  0x809bfeb in php3_request_startup () at main.c:668
#3  0x809d50e in apache_php3_module_main (r=0x82df034, fd=27, 
    display_source_mode=0, preprocessed=0) at main.c:1902
#4  0x809aa42 in send_php3 ()
#5  0x809aaa6 in send_parsed_php3 ()
#6  0x8108f4b in ap_invoke_handler ()
#7  0x811be71 in process_request_internal ()
#8  0x811bed0 in ap_process_request ()
#9  0x8113845 in child_main ()
#10 0x81139e8 in make_child ()
#11 0x8113b43 in startup_children ()
#12 0x81140f4 in standalone_main ()
#13 0x811495b in main ()
#14 0x807645d in _start ()
(gdb) 

 [1999-10-06 22:32 UTC] gashalot at gashalot dot com
I have successfully narrowed this down to the mod_frontpage module, 
since when I remove that everything works properly.  As soon as I can find a
patch I'll post the resolution to this bug, and hopefully someone will close it.
 [2002-06-16 08:58 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Apr 05 10:01:27 2020 UTC