php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24369 Error: 1285-302 The parse tree is too large.
Submitted: 2003-06-27 18:03 UTC Modified: 2003-07-07 19:01 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: bxny78 at yahoo dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.3.2 OS: aix 5.1
Private report: No CVE-ID: None
 [2003-06-27 18:03 UTC] bxny78 at yahoo dot com
Description:
------------
I have the below error message when running "make" on aix 5.1 with gcc 2.9-aix51-020209

Reproduce code:
---------------
configure went ok...

Expected result:
----------------
no errors ;-)

Actual result:
--------------
        gcc  -IZend/ -I/php/php-4.3.2/Zend/ -DPHP_ATOM_INC -I/php/php432/include
 -I/php/php432/main -I/php/php-4.3.2 -I/php/php432/Zend -I/usr/local/include -I/
php/php-4.3.2/ext/xml/expat -I/php/php-4.3.2/main -I/php/php-4.3.2/Zend -I/php/p
hp-4.3.2/TSRM  -I/php/php432/TSRM  -g -O2  -c Zend/zend_language_parser.c -o Zen
d/zend_language_parser.o  && echo > Zend/zend_language_parser.lo
        lex -Pzend -S/php/php-4.3.2/Zend/flex.skl -oZend/zend_language_scanner.c
 -i /php/php-4.3.2/Zend/zend_language_scanner.l
0: Warning: 1285-300 The P flag is not valid.
0: Warning: 1285-300 The z flag is not valid.
0: Warning: 1285-300 The e flag is not valid.
0: Warning: 1285-300 The d flag is not valid.
0: Warning: 1285-300 The S flag is not valid.
0: Warning: 1285-300 The / flag is not valid.
0: Warning: 1285-300 The p flag is not valid.
0: Warning: 1285-300 The h flag is not valid.
0: Warning: 1285-300 The p flag is not valid.
0: Warning: 1285-300 The / flag is not valid.
0: Warning: 1285-300 The p flag is not valid.
0: Warning: 1285-300 The h flag is not valid.
0: Warning: 1285-300 The p flag is not valid.
0: Warning: 1285-300 The - flag is not valid.
0: Warning: 1285-300 The 4 flag is not valid.
0: Warning: 1285-300 The . flag is not valid.
0: Warning: 1285-300 The 3 flag is not valid.
0: Warning: 1285-300 The . flag is not valid.
0: Warning: 1285-300 The 2 flag is not valid.
0: Warning: 1285-300 The / flag is not valid.
0: Warning: 1285-300 The Z flag is not valid.
0: Warning: 1285-300 The e flag is not valid.
0: Warning: 1285-300 The d flag is not valid.
0: Warning: 1285-300 The / flag is not valid.
0: Warning: 1285-300 The f flag is not valid.
0: Warning: 1285-300 The l flag is not valid.
0: Warning: 1285-300 The e flag is not valid.
0: Warning: 1285-300 The x flag is not valid.
0: Warning: 1285-300 The . flag is not valid.
0: Warning: 1285-300 The s flag is not valid.
0: Warning: 1285-300 The k flag is not valid.
0: Warning: 1285-300 The l flag is not valid.
0: Warning: 1285-300 The o flag is not valid.
0: Warning: 1285-300 The Z flag is not valid.
0: Warning: 1285-300 The e flag is not valid.
0: Warning: 1285-300 The d flag is not valid.
0: Warning: 1285-300 The / flag is not valid.
0: Warning: 1285-300 The z flag is not valid.
0: Warning: 1285-300 The e flag is not valid.
0: Warning: 1285-300 The d flag is not valid.
0: Warning: 1285-300 The _ flag is not valid.
0: Warning: 1285-300 The l flag is not valid.
0: Warning: 1285-300 The a flag is not valid.
0: Warning: 1285-300 The g flag is not valid.
0: Warning: 1285-300 The u flag is not valid.
0: Warning: 1285-300 The a flag is not valid.
0: Warning: 1285-300 The g flag is not valid.
0: Warning: 1285-300 The e flag is not valid.
0: Warning: 1285-300 The _ flag is not valid.
0: Warning: 1285-300 The s flag is not valid.
0: Warning: 1285-300 The a flag is not valid.
0: Warning: 1285-300 The e flag is not valid.
0: Warning: 1285-339 Ratfor is not supported with lex.
0: Warning: 1285-300 The . flag is not valid.
0: Warning: 1285-300 The i flag is not valid.
1210: Error: 1285-302 The parse tree is too large.
        Try using the following: %e Number
make: 1254-004 The error code from the last command is 1.


Stop.
#

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-27 19:02 UTC] sniper@php.net
What was the configure line you used?

 [2003-07-02 22:46 UTC] bxny78 at aol dot com
Config line --

./configure --with-ibm-db2=/home/db2inst1/sqllib \
--with-apxs=/usr/HTTPServer/bin/apxs \
--prefix=/usr/HTTPServer/php \
--with-config-file-path=/usr/HTTPServer/php/conf \
--with-gd \
--with-jpeg-dir=/usr/lib/ \
--with-png-dir=/usr/local/include/libpng \
--with-odbc \
--with-zlib
 [2003-07-02 22:52 UTC] bxny78 at yahoo dot com
FYI - this same code was compiled on AIX 4.3.3 and works well, with the same level of everything (gcc, make, flex, bison, etc)
 [2003-07-03 05:19 UTC] sniper@php.net
I bet the compiler version is different in your AIX 4.3.3?
Doesn't the native compiler work? (instead of GCC)

 [2003-07-03 12:23 UTC] bxny78 at yahoo dot com
The native compiler had many other errors - as I was reading some other url - it seems like GNU gcc was prefered to compile php.

I tar the compiled binary from 4.3.3 and moved it to the 5.1 system and it's working...
 [2003-07-07 06:20 UTC] sniper@php.net
So which GCC version DO you have in that 4.3.3 machine?

 [2003-07-07 06:23 UTC] sniper@php.net
And install GNU flex too..

 [2003-07-07 16:45 UTC] bxny78 at yahoo dot com
Odd, but this is what works...
changed to libpng-1.0.15 instead of libpng-1.2.5

Not sure if Install order matters, here's what works...
zlib-1.1.4
libpng-1.0.15
libjpeg-6b-5
apache_1.3.27 (was unable to get it compiled with "IBM_HTTP_Server/1.3.6.4 Apache/1.3.7-dev")

Other issues were that the ext/gd path was missing some .h files, I copied all the .h/.c files from libjpeg to ext/gd/ and continue compile and it worked ok (missing files were jerror.h [I think] and another.

You can close this problem unless you'd like to document it more... I'll re-compile to add ssl/ldap soon and try to verify the source of my problems.
 [2003-07-07 16:49 UTC] bxny78 at yahoo dot com
Tools were GNU tools: 
bison-1.34-2
flex-2.5.4a-5
gcc-2.9
make.3.80
 [2003-07-07 19:01 UTC] sniper@php.net
I doubt it was the libpng. But it seems to be something in your system that is broken rather than in PHP..

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 12:01:25 2020 UTC