php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24328 symbol not found: executor_globals
Submitted: 2003-06-25 05:07 UTC Modified: 2003-07-12 21:13 UTC
From: Pavel dot Zakouril at mff dot cuni dot cz Assigned:
Status: No Feedback Package: Dynamic loading
PHP Version: 4.3.2 OS: UnixWare 7.1.1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-06-25 05:07 UTC] Pavel dot Zakouril at mff dot cuni dot cz
Description:
------------
I have installed PHP 4.3.2 by following way:

export ORACLE_HOME=/u01/app/oracle/product/8.1.7
export LD_LIBRARY_PATH=/usr/local/lib:$ORACLE_HOME/lib
export CC=cc
export EXTRA_LIBS='-lthread -lucb'
./configure --with-oci8=shared --with-apxs --without-mysql --without-pear --enable-sigchild
make
make install

Apache module works fine, but CLI version built at the same time fails with the following message:

ducklet 191# php
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20020429/liboci8.so' - dynamic linker: php: relocation error: symbol not found: executor_globals; referenced from: /usr/local/lib/php/extensions/no-debug-non-zts-20020429/liboci8.so in Unknown on line 0

What can be wrong ?



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-26 18:07 UTC] sniper@php.net
Where did that 'liboci8.so' come from? It should be just oci8.so.
What does 'ldd liboci8.so' output?
Why do you set EXTRA_LIBS before running configure..?

Does building oci8 via the phpize way work?
(cd ext/oci8 && phpize && ./configure --with-oci8=/u01/app/oracle/product/8.1.7 && make)


 [2003-06-27 02:51 UTC] Pavel dot Zakouril at mff dot cuni dot cz
> Where did that 'liboci8.so' come from?

It is built durig 'make' and installed during 'make install', as it was described in my first report.

> It should be just oci8.so.

??? All php extensions have names lib*.so under UnixWare.

> Why do you set EXTRA_LIBS before running configure..?

Answer to question 'why -lthread must be in EXTRA_LIBS ?' you can find at http://php.cz/manual/en/ref.oci8.php. And if I do not include -lucb into EXTRA_LIBS, I will get an error 'undefined symbol alloca' when starting php.

Note what I wrote in my first report: Apache module (using the same liboci8.so) works fine, problem is only with the CLI version.

But anyway, (cd ext/oci8 && phpize && ./configure
--with-oci8=/u01/app/oracle/product/8.1.7 && make) produces the following output:

UX:sh (phpize): ERROR: aclocal: Not found
UX:sh (phpize): ERROR: autoconf: Not found
UX:sh (phpize): ERROR: autoheader: Not found
You should add the contents of `/usr/local/share/aclocal/libtool.m4' to `aclocal
.m4'.
Configuring for:
  PHP Api Version:   20020918
  Zend Module Api No:   20020429
  Zend Extension Api No:   20021010
zsh: no such file or directory: ./configure
 [2003-07-12 21:13 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 22:03:39 2021 UTC