php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24282 Strange Open Base Dir Restriction Errors
Submitted: 2003-06-21 20:49 UTC Modified: 2004-01-28 14:23 UTC
Votes:21
Avg. Score:4.8 ± 0.5
Reproduced:20 of 20 (100.0%)
Same Version:11 (55.0%)
Same OS:10 (50.0%)
From: matzrek at shw-networks dot de Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.3.2 OS: Suse Linux 8.2 / Apache 1.3.27
Private report: No CVE-ID:
 [2003-06-21 20:49 UTC] matzrek at shw-networks dot de
Description:
------------
Executing my PHP Script sometimes produces errors like this :

Warning: Unknown(): open_basedir restriction in effect. File(/home/Domain1.com/htdocs/admin/index.php) is not within the allowed path(s): (/home/Domain2.de/) in Unknown on line 0 

if i hit Reload the scripts will work fine. Of couse the script doesn't try to include files from /home/Domain2.de. Its not a problem of a spezial script, because many customers complained about this.

Setting php_admin_value open_base_dir to none or "/" or "/home" doesnt solve this problem. safemode is disables (in vhost)

Seems to be the same bug discussed here http://bugs.php.net/bug.php?id=19292 for a former Version


Reproduce code:
---------------
<% phpinfo() ; %>


Expected result:
----------------
PHP Info Page

Actual result:
--------------
requesting www.shw-networks.de/info.php : this error sems to apear only at the first page request !!


Warning: Unknown(): open_basedir restriction in effect. File(/home/shw-network.de/htdocs/info.php) is not within the allowed path(s): (/home/xyz.de/) in Unknown on line 0

Warning: Unknown(/home/shw-network.de/htdocs/info.php): failed to open stream: Operation not permitted in Unknown on line 0

Warning: (null)(): Failed opening '/home/shw-network.de/htdocs/info.php' for inclusion (include_path='.:/usr/share/php') in Unknown on line 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-04 00:50 UTC] sniper@php.net
See bug #25753 (placeholder for all these reports about leaking php ini settings)
 [2004-01-28 14:23 UTC] sniper@php.net
This should now be fixed in CVS. Fix scheduled for PHP 4.3.5.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 12:02:07 2014 UTC