php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24200 Php with Sblatron Intall error
Submitted: 2003-06-16 02:56 UTC Modified: 2003-06-16 08:31 UTC
From: balin at myrealbox dot com Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.3.2 OS: redhat 8.0
Private report: No CVE-ID: None
 [2003-06-16 02:56 UTC] balin at myrealbox dot com
Description:
------------
in make after succsefull configure, this error:

Reproduce code:
---------------
/usr/local/lib/libsablot.so: undefined reference to `operator new[](unsigned)'
/usr/local/lib/libsablot.so: undefined reference to `SabArena::armalloc(int, int)'
/usr/local/lib/libsablot.so: undefined reference to `SabArena::dispose()'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator delete(void*)'
/usr/local/lib/libsablot.so: undefined reference to `__gxx_personality_v0'
/usr/local/lib/libsablot.so: undefined reference to `__cxa_pure_virtual'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `SabArena::arfree(void*)'
/usr/local/lib/libsablot.so: undefined reference to `operator delete[](void*)'
/usr/local/lib/libsablot.so: undefined reference to `SabArena::SabArena[in-charge](int)'
/usr/local/lib/libsablot.so: undefined reference to `SabArena::~SabArena [in-charge]()'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__vmi_class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator new(unsigned)'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-16 08:31 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

Try search the bug database before submitting any reports..

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 13:01:47 2020 UTC