php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24170 Configure fails because floorf doesn't exists
Submitted: 2003-06-13 05:30 UTC Modified: 2003-06-13 07:24 UTC
From: l_faillie at yahoo dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.3.2 OS: HP-UX
Private report: No CVE-ID: None
 [2003-06-13 05:30 UTC] l_faillie at yahoo dot com
Description:
------------
configure fails w/ following messages :

checking for floorf... no
configure: error: libjpeg.(a|so) not found.

I've checked error log and the faulty test is :

configure: failed program was:
#line 28040 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char floorf(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char floorf();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_floorf) || defined (__stub___floorf)
choke me
#else
floorf();
#endif

; return 0; }


I made some checks and it seems floorf() doesn't exists at all on my HP-UX boxes (10.20 and 11.00).
I think it's the same problem for bug #23322, #21924 and #21973

Bye

Laurent



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-13 06:54 UTC] l_faillie at yahoo dot com
I made some check : this function is only used in ext/gd/libgd/gd.c and every thing is made to works even if floorf miss.

So, for me, it's a configure script bug : it fails whereas it has only said 'floorf = no'.
 [2003-06-13 07:19 UTC] sniper@php.net
Check for the LAST lines of the config.log, the real
reason why the configure fails is really mentioned there.
Missing floorf() does NOT make the test fail.

You didn't tell what your configure line was, so I assume it's wrong. 

Not PHP bug -> bogus.

 [2003-06-13 07:21 UTC] sniper@php.net
Forget the config.log, the test failure is because libjpeg.so   
 or libjpeg.a was not found under the given path (?), /usr/lib or /usr/local/lib

 [2003-06-13 07:24 UTC] l_faillie at yahoo dot com
Oups ... forget it : I made a STUPID mistake :-(
Sorry.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 17:01:31 2024 UTC