php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24058 Sablotron extension missing -ljs flag
Submitted: 2003-06-06 08:24 UTC Modified: 2003-06-06 09:34 UTC
From: lindsay dot marshall at ncl dot ac dot uk Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.3.2 OS: Redhat 8.0
Private report: No CVE-ID: None
 [2003-06-06 08:24 UTC] lindsay dot marshall at ncl dot ac dot uk
If you add the sablotron support extension, the -ljs flag is not included in the appropriate LIB defines in files for installing with Apache so Apache configuration fails.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-06 09:08 UTC] sniper@php.net
And what was the full configure line you used?

 [2003-06-06 09:19 UTC] lindsay dot marshall at ncl dot ac dot uk
The command line was 

./configure  --with-apache=../apache_1.3.27 --enable-trackvars --with-mysql=/opt/mysql4 --enable-calendar --with-mhash --without-pear --with-imap=/opt/imap --with-imap-ssl --disable-session --enable-xslt --with-xslt-sablot --with-xmlrpc
 [2003-06-06 09:21 UTC] sniper@php.net
You need to add --with-sablot-js too.


 [2003-06-06 09:34 UTC] lindsay dot marshall at ncl dot ac dot uk
Ah, mea culpa. My excuse is that I know nothing about Sablotron is compiled and just loaded the RPM, so the documentation about flags did not mean anything to me. Perhaps  a note could be added to the documentation about this?

Thanks and sorry for the time waste.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 14:01:23 2020 UTC