|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24005 Distributions version of mnoGoSearch extension does not work with MySQL 4
Submitted: 2003-06-03 21:24 UTC Modified: 2003-06-26 18:20 UTC
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: paul at ensigma dot com dot au Assigned: gluke (profile)
Status: No Feedback Package: mnoGoSearch related
PHP Version: 4.3.2 OS: RedHat 9
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-06-03 21:24 UTC] paul at ensigma dot com dot au
I tried to compile PHP-4.3.2 with the --with-mnogosearch option and with MySQL 4.0.13 installed from RPM .

./configure --with-mysql=/usr --with-gd --with-ttf --enable-track-vars  --with-apxs2=/usr/local/apache2/bin/apxs --with-mnogosearch --with-jpeg-dir=/root/source/jpeg-6b/  --with-png-dir=/usr/local/lib/libpng.a --with-zlib-dir=/usr/local/lib/zlib.a --with-tiff-dir=/usr/local/lib/libtiff.a --with-mnogosearch 

It failed complaining about "ext/mysql/phpmysql.c: undefined reference to mysql_create_db". I downloaded the latest php-extension from (mnogosearch-php-extension-1.7.3.tar.gz) and replaced the contents of ext/mnogosearch with the files in this archive and it all worked a treat (with a quick edit to remove the second reference to -lmysqlclient in the EXTRA_LIBS line the PHP Makefile... but I think that mnoGo's fault!)


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-06 06:32 UTC]
Sergey, deal with this.

 [2003-06-10 09:34 UTC]
It seems to be because of buggy gcc-3.x compiler in your distribution. The normal gcc behavior is to ignore -l switch dupes.
 [2003-06-10 23:09 UTC] paul at ensigma dot com dot au
There is still the issue of the old version of mnoGoSearch in the 4.3.2 source code... has that been updated??
 [2003-06-11 00:49 UTC]
Yes. I will update PHP_4_3 source code branch soon.
It means that updates extension will go to possible PHP-4.3.3 release in future.
 [2003-06-15 22:21 UTC]
Please try using this CVS snapshot:
For Windows:

It should now have the latest mnogosearch extension.

 [2003-06-26 18:20 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Feb 22 18:01:37 2024 UTC