php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23978 CyberMut extension v1.0 compilation error
Submitted: 2003-06-03 05:29 UTC Modified: 2003-06-03 06:12 UTC
From: k dot przybylski at connectis dot fr Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.2 OS: Linux
Private report: No CVE-ID: None
 [2003-06-03 05:29 UTC] k dot przybylski at connectis dot fr
while using
pear -v install cybermut

the cybermut-1.0/configure part works fine
but at the compilation there is an error in
cybermut-1.0/cybermut.c line 51

`cybermut_functions' undeclared here (not in a function)

the problem lies in the file cybermut.c line 39 which reads :

function_entry spplus_functions[] = {

i don't know what 'spplus' is doing here (i think it's a mixup beetween the spplus and the cybermut module because it's the same maintainer in charge for both extensions),
but i replaced it to read :

function_entry cybermut_functions[] = {

and everything worked fine

i have checked in the CVS tree if the problem is already fixed but it's not

please assign this bug to nicos (CHAILLAN Nicolas).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-03 06:12 UTC] nicos@php.net
This bug is fixed.

I've just released 1.1.

http://pear.php.net/get/cybermut-1.1.tgz

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 00:03:42 2021 UTC