php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23966 error in php_pdf.dll
Submitted: 2003-06-02 17:18 UTC Modified: 2003-06-03 08:13 UTC
From: brandon dot whitehead at orst dot edu Assigned:
Status: Not a bug Package: PDF related
PHP Version: 4.3.2 OS: Windows XP
Private report: No CVE-ID: None
 [2003-06-02 17:18 UTC] brandon dot whitehead at orst dot edu
php_pdf.dll (28 May 2003) will not load under PHP4.3.2/Apache2.0.43.

If I replace the php_pdf.dll in the 28 May 2003 distribution with the one from the 15 Feb 2003 distribution, PHP loads fine.

Both files were taken from precompiled Win32 binaries.

Hopefully this is not a local configuration problem.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-02 17:21 UTC] sniper@php.net
And did you replace the old dlls/ with the new ones from the 4.3.2 package?? Especially the FDFTK.DLL file..

 [2003-06-02 17:22 UTC] sniper@php.net
I need to learn to read..but same issue, replace the old
dlls found in dlls/ folder in the 4.3.2 zip package..

And make sure you have only ONE php4ts.dll in your system
and that it is from the new ZIP package too.

 [2003-06-02 17:40 UTC] brandon dot whitehead at orst dot edu
I replaced the following DLLs that I currently use with the newest versions: iconv.dll, sablot.dll, expat.dll

FDFTK.DLL was not previously installed in my system path.  Installing it in windows\system32 did not change/solve the problem.  I am using the newest php4apache2 and php4ts dlls.

Currently the older php_pdf.dll works and the new one does not.

Next: 

I copied all dlls from the dll folder of the 28 May PHP distribution to my windows\system32 folder overwriting all previous dlls.  Again, the older php_pdf.dll works and the new ones does not.

For what its worth, dependency walker reports an error with php4ts.dll.

I then found that I had an old version of php4ts.dll in my windows\system32

Replacing this with the new version solved the problem.
 [2003-06-03 08:13 UTC] sniper@php.net
We really should make this a FAQ since this is the most common problem within Windows users..

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jan 19 01:01:25 2019 UTC