php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23928 Firebird 1.5 not supported
Submitted: 2003-05-31 14:24 UTC Modified: 2003-06-04 02:23 UTC
From: igor at gelios dot net Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.3.2 OS: Linux RedHat 9
Private report: No CVE-ID: None
 [2003-05-31 14:24 UTC] igor at gelios dot net
Firebird (www.firebirdsql.org) is a main opensource clone of Interbase.

Firebird 1.0.2 (current stable release) work with php almost fine.

But Firebird 1.5 (RC2 now available) was rewritten with C++ and php 4.3.2 can't be compiled with this release - configure failed.

Firebird, not Borland Interbase, is now main variant for interbase-like sql server and php MUST support it ;) 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-01 05:06 UTC] daniela@php.net
try this:

1)
-add in your php_interbase.h this line:
#define ISC_FAR

2)
-before ./configure
export LIBS="-lstdc++ -lcrypto"

3) 
if you use FB1.5RC2 .rpm there is a bug.
check in your syslog. You will see an error
looking for firebird.conf in a wrong path.
Adjust it (with right permissions too)


 [2003-06-03 12:43 UTC] igor at gelios dot net
After export LIBS="-lstdc++ -lcrypto":

configure: error: installation or configuration problem: C compiler cannot create executables.

;(
 [2003-06-03 13:27 UTC] igor at gelios dot net
I'm sorry ;)
Not "-lcrypto", but "-lcrypt".

Thanks, it works now!  (FB1.5 RC3 + PHP 4.3.2)
 [2003-06-04 02:23 UTC] daniela@php.net
Closed
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Dec 12 17:01:26 2018 UTC