php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23912 Illegal CSS in phpinfo() output
Submitted: 2003-05-30 19:28 UTC Modified: 2003-06-02 19:07 UTC
From: fischer at lavielle dot com Assigned: iliaa (profile)
Status: Closed Package: *General Issues
PHP Version: 4.3.2 OS: Mac OS X (All?)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
39 - 26 = ?
Subscribe to this entry?

 
 [2003-05-30 19:28 UTC] fischer at lavielle dot com
In the file php-4.3.2/ext/standard/css.c line 40 the 
CSS reads:

	PUTS(".center th { text-align: center; !important 
}\n");

It should read:

	PUTS(".center th { text-align: center !important; 
}\n");

(note the position of the semicolon, which should 
follow the word important)

Check out <http://www.w3.org/TR/CSS2/grammar.html> for 
the official word on where the semicolon should go. I 
interpret my correction to be correct and the fix 
resolves the bug in Safari.

This mistake makes Safari render the output very 
different to what was intended.

Mike

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-30 21:03 UTC] iliaa@php.net
There are a few w3 compliance issues with the css on phpinfo(), all should and will be fixed prior to the next release.
 [2003-06-02 19:07 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu May 28 13:01:29 2020 UTC