php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23883 PHP crashes if snmp module loaded
Submitted: 2003-05-29 20:26 UTC Modified: 2003-06-09 23:43 UTC
From: joey at joeysmith dot com Assigned:
Status: Not a bug Package: SNMP related
PHP Version: 4.3.2 OS: Debian sarge (testing)
Private report: No CVE-ID: None
 [2003-05-29 20:26 UTC] joey at joeysmith dot com
#0  0x4038a2ff in mallopt () from /lib/libc.so.6
#1  0x403892ca in free () from /lib/libc.so.6
#2  0x42e18700 in sc_hash () from /usr/lib/libsnmp-0.4.2.so
#3  0x42e17c4b in hash_engineID () from /usr/lib/libsnmp-0.4.2.so
#4  0x42e17b46 in search_enginetime_list () from /usr/lib/libsnmp-0.4.2.so
#5  0x42e17976 in set_enginetime () from /usr/lib/libsnmp-0.4.2.so
#6  0x42e0fcc4 in init_snmpv3_post_config () from /usr/lib/libsnmp-0.4.2.so
#7  0x42e1905d in snmp_call_callbacks () from /usr/lib/libsnmp-0.4.2.so
#8  0x42e0b7b4 in read_configs () from /usr/lib/libsnmp-0.4.2.so
#9  0x42df1f37 in init_snmp () from /usr/lib/libsnmp-0.4.2.so
#10 0x42c415bc in zm_startup_snmp () from /usr/lib/php/20020429-debug/snmp.so
#11 0x080c7286 in php_dl (file=0x81df5e8, type=1, return_value=0xbffff8a0) at /home/joey/src/php-4.3.2/ext/standard/dl.c:238
        handle = (void *) 0x8260de8
        libpath = 0x81daa2c 'Z' <repeats 36 times>, "\204\xcc\217*\217*"
        module_entry = (zend_module_entry *) 0x42c45560
        tmp = (zend_module_entry *) 0x8260d70
        get_module = (zend_module_entry *(*)(void)) 0x42c41570 <get_module>
        error_type = 32
        extension_dir = 0x81922f5 "/usr/lib/php/20020429-debug"
#12 0x0812adb6 in php_load_function_extension_cb (arg=0x81df5e8) at /home/joey/src/php-4.3.2/main/php_ini.c:218
        extension = (zval *) 0x81df5e8
        zval = {value = {lval = 1, dval = 4.9406564584124654e-324, str = {val = 0x1 <Address 0x1 out of bounds>, len = 0},
    ht = 0x1, obj = {ce = 0x1, properties = 0x0}}, type = 6 '\006', is_ref = 248 '\xf8', refcount = 49151}
#13 0x0814fa5b in zend_llist_apply (l=0x81d093c, func=0x812ad99 <php_load_function_extension_cb>)
    at /home/joey/src/php-4.3.2/Zend/zend_llist.c:189
        element = (zend_llist_element *) 0x81df5e0
#14 0x0812b36e in php_ini_delayed_modules_startup () at /home/joey/src/php-4.3.2/main/php_ini.c:478
No locals.
#15 0x08126d01 in php_module_startup (sf=0x81cf700, additional_modules=0x0, num_additional_modules=0)
    at /home/joey/src/php-4.3.2/main/main.c:1215
        zuf = {error_function = 0x8125979 <php_error_cb>, printf_function = 0x81253c2 <php_printf>,
  write_function = 0x8126827 <php_body_write_wrapper>, fopen_function = 0x8125f4d <php_fopen_wrapper_for_zend>,
  message_handler = 0x8125fcb <php_message_handler_for_zend>, block_interruptions = 0, unblock_interruptions = 0,
  get_configuration_directive = 0x8125f80 <php_get_configuration_directive_for_zend>, ticks_function = 0x81307d0 <php_run_ticks>,
  on_timeout = 0x81262c6 <php_on_timeout>}
        zuv = {import_use_extension = 0x819f730 ".php", import_use_extension_length = 1073779424, html_errors = 1 '\001'}
        module_number = 0
        php_os = 0x819f6a8 "Linux"
        i = 6
#16 0x0816c02e in main (argc=2, argv=0xbffffb64) at /home/joey/src/php-4.3.2/sapi/cli/php_cli.c:520
        exit_status = 0
        c = -1
        file_handle = {type = 88 'X', filename = 0xbffffae4 "0\221", opened_path = 0x4002908e "[\201\xc3\xe6 ", handle = {
    fd = 1073812652, fp = 0x400114ac}, free_filename = 56 '8'}
        behavior = 1
        no_headers = 1
        orig_optind = 1
        orig_optarg = 0x0
        arg_free = 0x0
        arg_excp = (char **) 0xbffffaac
        script_file = 0x0
        global_vars = {head = 0x4032ae40, tail = 0x4031c248, size = 1074981870, count = 1075467648, dtor = 0x40053258,
  persistent = 216 '\xd8', traverse_ptr = 0x2f2f2f2f}
        interactive = 0
        is_hashbang = 0
        module_started = 0
        exec_direct = 0x0
        param_error = 0x0


dpkg -S /usr/lib/libsnmp-0.4.2.so
libsnmp4.2: /usr/lib/libsnmp-0.4.2.so
-->apt-cache policy libsnmp4.2
libsnmp4.2:
  Installed: 4.2.5-3.3
  Candidate: 4.2.5-3.3
  Version Table:
 *** 4.2.5-3.3 0
        100 http://debian.lcs.mit.edu sarge/main Packages
        100 /var/lib/dpkg/status

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-01 20:49 UTC] sniper@php.net
And how was PHP configured? Why don't you use more recent
net-snmp libs anyway? (it looks more like a crash in there..)

 [2003-06-01 21:14 UTC] joey at joeysmith dot com
./configure --with-snmp is sufficent to reproduce this bug.

I'd be surprised if this were an SNMP bug, as the only thing I have to do to duplicate this bug is to run the PHP cli with SNMP enabled. e.g., /usr/bin/php -v
 [2003-06-02 06:37 UTC] sniper@php.net
It works just fine here with net-snmp-5.0.6 so you really 
should try it..

 [2003-06-02 06:38 UTC] sniper@php.net
And/or compile it as static module, NOT shared.

 [2003-06-02 08:09 UTC] joey at joeysmith dot com
Using SNMP 5.0.7 (debian testing package libsnmp5-dev) still exhibits the crash. I'll build SNMP as static as well.
 [2003-06-02 10:28 UTC] sniper@php.net
Use the sources..not some debian package which is most likely broken anyway. (And no idea how it's configured either)

 [2003-06-09 08:43 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-06-09 15:36 UTC] joey at joeysmith dot com
> No feedback was provided. The bug is being suspended
> because we assume that you are no longer experiencing the > problem.

 That's a faulty assumption. No feedback was provided because I don't see the need to reply to the last comment.

> If this is not the case and you are able to provide the
> information that was requested earlier, please do so and
> change the status of the bug back to "Open". Thank you.

 Which information was requested? I don't see a request for information, only the implication that if PHP (and PHP alone) is causing crash bugs on a particular distro, that we don't want to try and resolve that.
 [2003-06-09 23:43 UTC] sniper@php.net
Joey, discussion about semantics belongs elsewhere, this is a bug database. And there is no bug as long as I can't reproduce it. :)

I asked you to try compiling the latest net-snmp version
from sources and link PHP with that as it works fine for me here..(and you're the only one reporting this problem so far anyway..)


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 17 22:01:22 2020 UTC