php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23861 php_gd2.dll - The Specified procedure cannot be found
Submitted: 2003-05-28 13:48 UTC Modified: 2003-05-29 22:45 UTC
From: steve at enerds dot ca Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.3.2RC4 OS: Windows
Private report: No CVE-ID: None
 [2003-05-28 13:48 UTC] steve at enerds dot ca
OS: Windows XP Professional, Sp1
Web Server: Apache 2.0.45 Win 32


In trying the new 4.3.2 RC4, I am trying to load the gd2 library without success.  When I modify my php.ini and un-comment the line:

extension=php_gd2.dll

I get the following error.  

Unknown(): Unable to load dynamic library 'c:\php\extensions\php_gd2.dll' - The specified procedure cannot be found

The dll does exist at that path, and I have verified it is actually being able to find it.   In changing the dll name to php_test.dll  the error message changes to the appropriate:

"The specified module cannot be found"


Regards,

~Steve

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-28 19:50 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.


This issue has come up over and over again. It's NOT a bug.
You've just installed PHP improperly. Ask further support
questions on the appropriate mailing list.

 [2003-05-28 21:57 UTC] steve at enerds dot ca
This is *NOT* a configuration problem.   Using 4.3.1, without changing my configuration file, paths, or anything else (just the appropriate dll's), it works - gd2 extension loads.   When I change to the 4.3.2 RC4 code, it does not work.  This is using the exact same machine, web server, configuration, etc.
 [2003-05-29 20:57 UTC] steve at enerds dot ca
I am still having the problem with multiple Windows machine, with different configurations.   In all cases, the gd2.dll loads with php 4.3.1, however when I upgrade to the RC 4.3.2 gd2 cannot load.  

Please advise.
Thanks in advance
 [2003-05-29 22:45 UTC] steve at enerds dot ca
*puts head down with sheepish grin*

For some reason or another our sysadmin had a copy of the dll's in c:\windows and c:\windows\system32.    Once I deleted those from c:\windows and updated those in c:\windows\system32
all was well.

Sorry for the inconvenience, appreciate the support
~Steve
 [2003-06-12 19:39 UTC] iridium at beyondunreal dot com
I am getting this bug as well, I am aware this one has been declared bogus, but I am curious.

I have found that php_gd2.dll and php_sockets.dll will not load at all in the latest version of PHP (4.3.2), but if I take the modules from PHP 4.3.0, they will both load using PHP 4.3.2.

I have made sure these are the only copies avaliable in the path, and I have tried as many locations to put these DLLs as you care to think of, but they still won't load.

Since the problem only seems to occour when I try to use the latest DLLs, doens't that mean something is wrong with the DLLs? 

To my knowledge, I have followed the install instructions quite carefully, and I am certain that all of the relevent (PHP) DLLs have been updated on my system to version 4.3.2. I have spent quite a while puzzling over this.

I'm running Apache 1.3.7 and PHP 4.3.2 on Windows XP Pro Sp1.

A friend of mine found that PHP wouldn't load on his system either if he tried to use the most recent gd2.dll.
 [2003-06-12 20:01 UTC] iridium at beyondunreal dot com
I am a stupid idiot/dolt person.

Gahh.

I found that there were php4ts.dll/php4apache.dlls in my apache executable directory that were out of date.

Updated them and the the problem disappeared.

Let this be a lesson.. search for *.dll!
 [2004-07-22 15:28 UTC] james at nuvola dot co dot uk
I too am having this problem. I have version 5.0.0 of php_gd2.dll, and now PHP 4.3.8.8 (having uninstalled 4.3.4 and installed this to try and fix the problem). My system has XP Pro with IIS 5.1.2600.1

The only php*.dll files I have on my machine are php4ts and php_gd2.

Whenever I try and call the image functions I get the same error: 'Unable to load dynamic library 'C:\WINDOWS\system32\php_gd2.dll' - The specified module could not be found'. The file is at this location. I also get a similar error when I try and register the DLL with regsvr32 on the command line, which leads me to suspect that it's something to do with the DLL and not how PHP uses it, or potentially a Windows configuration issue. Also, I've tried putting the DLL in various locations and no joy. Any ideas anyone??
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Apr 18 08:02:42 2024 UTC