|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23860 published regexp not working: ^(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).{4,8}$
Submitted: 2003-05-28 12:30 UTC Modified: 2003-06-11 19:12 UTC
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: jbarwick at sentienthealth dot com Assigned:
Status: No Feedback Package: PCRE related
PHP Version: 4.3.1 OS: Linux GlibC 2.1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-05-28 12:30 UTC] jbarwick at sentienthealth dot com
Very interesting problem...this published regexp:
was working with my PHP4.3.0 on Win32 platform
and on 4.3.0 on RedHat8.0 (all RH patches installed).
However, this regexp is NOT working on RedHat 9
with Apache 2.0.  Any ideas why?

Gives REG_BADRPT message....Simple regexp's DO work.

This regexp compiles if you remove the ?'s (but of 
course...will not do what I want it to!)...and of course
the string is:


taken directly from

BTW:  libiconv 1.8 is installed.  mbstring is loaded 
and all encodings are set to UTF8...yes, ereg is not 8 bit safe...know that...hope this ain't the problem.

4.3.1 was compiled with --with-regex=system...however, it appears to use "bundled" regexp anyway. (tried with regex=php and regex=system...both produce same used bundled regexp library).

this is NOT an Apache problem....php CGI version produces same results...even though somewhere in the depths I read "php must be compiled with the same regexp version as apache if php loaded as module".  I hear what this is saying, but I don't understand how to determine this...and, like I said...CGI version produces same result.

Mayble I'll try --with-regexp=apache...see what happens...

If this is the same thing as Bug #1683...sorry...please combine with that one....but...I'm not sure it's the same.

any response may be helpful...HLP!


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-05 08:46 UTC]
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

Please submit a short piece of code reproducing the issue.
 [2003-06-11 19:12 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 04:01:27 2024 UTC