php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23839 exec() system() passthru() does not work
Submitted: 2003-05-27 14:12 UTC Modified: 2003-06-04 08:04 UTC
From: flop dot m at usa dot net Assigned:
Status: Closed Package: Program Execution
PHP Version: 4.3.1 OS: Windows 2000
Private report: No CVE-ID: None
 [2003-05-27 14:12 UTC] flop dot m at usa dot net
Wanted to launch a batch file. None of those method function. It will just print the commands of the batch file - but won't execute any - which is weird as those commands should be executed by 'cmd'.

args used was "cmd /c some.bat" -> exec("cmd /c some.bat")

Just 'downdate' PHP to version 4.0.6 which works perfectly.

Any idea of where the problem is?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-27 14:14 UTC] derick@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

...
 [2003-06-02 17:28 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-06-04 08:04 UTC] flop dot m at usa dot net
I have tried the thing on another machine. It did work. So I guess I will have to investigate a little bit more by myself. I am closing the bug for now.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Dec 02 19:01:27 2023 UTC