|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23833 Cannot connect to Ingres II database (ingres_connect)
Submitted: 2003-05-27 10:16 UTC Modified: 2003-10-21 06:17 UTC
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: pm dot aubertel at free dot fr Assigned:
Status: Not a bug Package: Ingres II related
PHP Version: 4.3.2RC4 OS: Solaris 2.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
49 - 11 = ?
Subscribe to this entry?

 [2003-05-27 10:16 UTC] pm dot aubertel at free dot fr
After  compiling and installing successfully php 4.3.2 RC over Apache 1.3.27
with Ingres II support, I cannot get the ingres_connect function to work.

My php configure line is:
	./configure  --with-mysql

The apache start script contains the lines:
export II_SYSTEM

What I get in the apache error.log is:
[error] PHP Warning:  ingres_connect(): Ingres II:  Server or API error : Unable to authenticate client's user ID. in /export/home/www/dhs/php/readdb.php on line 28
[error] PHP Warning:  ingres_connect(): Ingres II:  SQLSTATE : 08004 in /export/home/www/dhs/php/readdb.php on line 28
[error] PHP Warning:  ingres_connect(): Ingres II:  Unable to connect to database (isis::basedhs15) in /export/home/www/dhs/php/readdb.php on line 28

What I get in the Ingres errorlog.log:
isis    ::[33034      IIGCN, 00000001]: Tue May 27 15:54:40 2003 E_GC1008_INVALID_USER  Unable to authenticate client's user ID.

I have tried different user/passwd, some of them regisrred with accessdb
but the result is always the same.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-27 17:45 UTC]
Someone mentioned in the manual that adding --disable-posix made it work for him..try adding that to your configure line.
(rm -f config.cache first!)

 [2003-05-28 03:16 UTC] pm dot aubertel at free dot fr
I just cleaned, recompile and re-install php with
--disable-posix and do the same for apache but
the result is the same.
 [2003-07-09 15:54 UTC]
Did you find any reasons why the sample program works and PHP not..?

 [2003-07-16 10:14 UTC] pm dot aubertel at free dot fr
I figured out what was wrong with the connexion.

After searching in Google for "E_GC1008_INVALID_USER",
I have found a post in the comp.databases.ingres forum
explaining a modification to do in Ingres.

It is related to Ingres security.

I had to modify the "config.dat" file in Ingres
using cbf. This is what I changed:

ii.<hostname>.gcf.mech.null.enabled:   false -> true
ii.<hostname>.gcf.security_mechanism:  ingres -> null

After that, I bounced Ingres and the php code worked.
 [2003-07-16 14:12 UTC]
Obviously not any PHP bug then -> bogus.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed May 29 09:01:33 2024 UTC