php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23676 error on processing instructions that begin with xml
Submitted: 2003-05-17 20:49 UTC Modified: 2003-05-23 08:11 UTC
From: brandon dot whitehead at orst dot edu Assigned: edink (profile)
Status: Not a bug Package: DOM XML related
PHP Version: 4.3.1 OS: Win32 (XP)
Private report: No CVE-ID: None
 [2003-05-17 20:49 UTC] brandon dot whitehead at orst dot edu
The DOMXML processor fails if it runs into processing instructions that BEGIN with any case composition of "XML".  See the rules here: http://www.w3.org/TR/REC-xml#sec-pi

For example "<?xmltarget ?>" would cause a failure.

Admittedly its a bit of a tricky definition, but basically, anything is valid except the following targets: "XML", "XMl", "XmL", "Xml", "xML", "xMl", "xmL", and "xml"

"xmltarget" is valid because there is not whitespace folliwng the "l"

Since LibXML appears to now be built into php_domxml.dll, I can not upgrade from the built in version of 2.04.30 to the current version of 2.05.07.  Therefore I am reporting it as a bug in PHP.  

I sincerely appologize if this is in some way bogus.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-18 08:42 UTC] sniper@php.net
Edin, update your libxml for the win32 build..

 [2003-05-18 10:23 UTC] rrichards@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

first 3 characters "xml" are reserved for any future standard PIs. Currently "xml-stylesheet" is also support.
Upgrading libxml will not change this as there have been no changes to this rule in their library.
 [2003-05-18 11:07 UTC] brandon dot whitehead at orst dot edu
It is a bit of a confusing definition, because the defintion of a PI excludes instances of "XML" explicitly, yet it is already accounted for in the "Name" definition upon which it is based.  I therefore find fault with the W3's recommendation.

Unfortunately, the bug must therefore be in XML Spy which is the program that is generating the violating xml pi.
 [2003-05-23 08:11 UTC] edink@php.net
Btw. libxml is upgraded to 2.5.7.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 00:01:34 2019 UTC