php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23617 Your website gives me a php error
Submitted: 2003-05-13 15:46 UTC Modified: 2003-05-14 16:33 UTC
From: jake at olefsky dot com Assigned:
Status: Not a bug Package: Website problem
PHP Version: 4.3.2RC2 OS: Your website
Private report: No CVE-ID: None
 [2003-05-13 15:46 UTC] jake at olefsky dot com
When I load up your website's front page (php.net), I get this error:

Parse error: parse error in /local/Web/sites/phpweb/include/ip-to-country.inc on line 99

I am coming from behind a corporate firewall in Palo Alto, CA.

-Jake

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-13 15:58 UTC] sniper@php.net
reclassified.

 [2003-05-13 16:56 UTC] alindeman@php.net
I do not see this error -- it may have been fixed.  Please re-open if it's still there and give a more details explanation of where it is, etc...
 [2003-05-13 20:12 UTC] jake at olefsky dot com
Still there.  I just go to www.php.net and at the very top of the page, before anything is printed I get that error.  It only happens on the front page.  If I go to any other sub-page I do not get the error.  It doesnt appear to effect any functionality of the site, its just a little annoying and its been happening for several weeks.
 [2003-05-13 20:20 UTC] alindeman@php.net
I still can't see this.  I even went so far as viewing the source and searching for 'error'.  Nothing.  Try shift+refreshing your browser and clearing your browser cache.   

Also, are you sure you're on the main php.net website and not a mirror?
 [2003-05-14 10:51 UTC] pollita@php.net
This was fixed fairly quickly upon being introduced, several changes are being made on the php.net site, we apologize for temporary errors which occur during this process.
 [2003-05-14 11:15 UTC] jake at olefsky dot com
This isn't a temporary error.  Its been happening for over 2 weeks.  I took a snapshot of the error 5 minutes ago.  You can see it here:

http://offsky.com/transfer/example.jpg

The error doesnt bother me, I just thought I'd be a good samaritan.
 [2003-05-14 12:27 UTC] pollita@php.net
I *do* appreciate your desire to help out but there is definately some critical piece of information missing here.

#1) That snap is *not* 5 minutes old.  That much is obvious from the missing news item.

#2) Noone else is seeing that error message since it was last fixed.

My *theory*, is that your corporate firewall is caching the page.  This would explain the lack of the most recent news item (which was added two days ago) and the presense of the error message despite the script having been fixed.

I'd like you to try something to circumvent possible caching by your firewall.

Browse to: http://www.php.net/?a=12345

This *should* tell any caching proxy to forcibly reload the page (using the GET parameter).  This may or may not work, but it's the simplest approach.

Baring that, try the following script from behind your firewall:

<?php
  $fp = fopen('http://www.php.net', 'r');
  var_dump($http_response_header);  
?>

If the page is being cached, the caching proxy should tell you in the response header when it was originally rendered.

Thanks in advance for taking the time to explore this.
 [2003-05-14 12:28 UTC] goba@php.net
This must come from cache. This error was fixed days before... We also have an Activestate awards news item since yesterday, so I am sure you are not seeing a fresh copy of the page.
 [2003-05-14 16:23 UTC] jake at olefsky dot com
It was the cache! Dang proxy!

I'm sorry for leading you on a wild goose chase. Thanks for your responses.  Its good to see an active and responsive bug resolving crew.

-Jake
 [2003-05-14 16:33 UTC] goba@php.net
Should be bogus, as no bug existed to correct...
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 07:03:48 2022 UTC