php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23592 Go-PEAR 0.2.2 Webfrontend - broken link to Start Web Frontend
Submitted: 2003-05-12 08:24 UTC Modified: 2004-09-01 16:39 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:0 of 0 (0.0%)
From: ths at 4bconsult dot de Assigned: pajoye (profile)
Status: Not a bug Package: PEAR related
PHP Version: 4.3.1 OS: WIN
Private report: No CVE-ID: None
 [2003-05-12 08:24 UTC] ths at 4bconsult dot de
The Link [ Start Web Frontend of the PEAR Installer >> ]
is on my Windows system:

http://developer.ths/test/go-pear/\test\go-pear/index.php

but should be:

http://developer.ths/test/go-pear/index.php

_SERVER["DOCUMENT_ROOT"] is d:/docroots/developer


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-03 19:21 UTC] pajoye@php.net
Can you try with latest cvs?

I cannot reproduce it now on XP and linux boxes.

thank's

pierre
 [2003-06-04 04:48 UTC] ths at 4bconsult dot de
I can't find go-pear in CVS. Where is it located?

Ok, http://go-pear.org/ is maybe the same...
$Id: go-pear,v 1.44 2003/06/03 23:57:57 pajoye Exp $

The Link is now:

go-pear/index.php

but should be:

/go-pear/index.php
 [2003-06-04 05:17 UTC] ths at 4bconsult dot de
Sorry, I run the last test in a different directory (http://developer.ths/go-pear/).

When I place the go-pear script in http://developer.ths/test/go-pear/ as original reported the problem is still the same:

The given Link is relative:

test\go-pear/index.php

but should be absolut:

/test/go-pear/index.php

In this case I also get an Warning within "Installation in progress ...":
...
Downloading package: phpUnit..........ok
Extracting installer..................ok
warning : bad md5sum for file d:\docroots\developer\test\go-pear\pear.bat
install ok: PEAR 1.1
install ok: Archive_Tar 1.1
...

An request to the index.php fails with:

Parse error: parse error, unexpected T_STRING in d:\docroots\developer\test\go-pear\index.php on line 76
 [2003-06-25 04:10 UTC] ths at 4bconsult dot de
Update. Test with go-pear,v 1.47

There is still a problem with the link:

<a href="path_with_go-pear/index.php" ...>

should be

<a href="/path_with_go-pear/index.php" ...>

or 

<a href="index.php" ...>

The request to the index.php still fails with:

Parse error: parse error, unexpected T_STRING in
d:\docroots\developer\path_with_go-pear\index.php on line 76

The reason is an backslash at end of path escaping the single quote...

71: if ($env=getenv('PHP_PEAR_PHP_BIN')) {
72:     define("PHP_PEAR_PHP_BIN",$env);
73: } else {
74:     putenv('PHP_PEAR_PHP_BIN=d:\docroots\developer\path_with_go-pear\');
75: }

This (maybe) can be removed because there is also:

48: if ($env=getenv('PHP_PEAR_BIN_DIR')) {
49:     define("PHP_PEAR_BIN_DIR",$env);
50: } else {
51:     putenv('PHP_PEAR_BIN_DIR=d:\docroots\developer\path_with_go-pear');
52: }

..and this works fine.
 [2004-05-24 10:11 UTC] pajoye@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Hello,

Try a snapshot and report it again if this problem still exists, using pear.php.net/bugs/
 [2004-05-27 15:50 UTC] ths at 4bconsult dot de
The Problem with the link 
[ Start Web Frontend of the PEAR Installer >> ]
still exists.

<a href="path_with_go-pear.php/index.php" ...>

should be

<a href="/path_with_go-pear.php/index.php" ...>

or 

<a href="index.php" ...>


After correct this manually the request of index.php fails because it don't use the PEAR installed by default in path_with_go-pear.php/PEAR
 [2004-06-04 15:25 UTC] kuzgunisiyah at yahoo dot com
burak basaran
 [2004-09-01 16:35 UTC] alan_k@php.net
can you report this on pear.php.net if the problem still exists - where the package maintainers now manage pear bugs
 [2004-09-01 16:39 UTC] alan_k@php.net
Bogusing - pear bugs on bugs.php.net are unlikely to get any attention
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Feb 23 17:01:28 2020 UTC