php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23571 pear package not including correct files
Submitted: 2003-05-09 21:58 UTC Modified: 2003-05-11 14:58 UTC
From: davey@php.net Assigned: vblavet (profile)
Status: Closed Package: PEAR related
PHP Version: 4CVS-2003-05-09 (stable) OS: Win32 (XP)
Private report: No CVE-ID: None
 [2003-05-09 21:58 UTC] davey@php.net
Using two snaps newer than 4.3.2RC2 (200305071630 and the latest - 200305100030) pear package only includes package.xml inside the tgz file. I am using the bundled PEAR files, so PEAR 1.1.

I have verified this on PEAR_Info (1.0.4 and 1.0.5) and Auth_HMAC (still being proposed), both package correctly with PHP 4.3.1 and PEAR 1.0.1

Checks are fine:
C:\web\php-cvs\pear\PEAR_Info>pear pv
Validation: 0 error(s), 0 warning(s)

Build seems to go fine:
C:\web\php-cvs\pear\PEAR_Info>pear package
Analyzing Info.php
Analyzing tests\pear_info.php
Package C:\web\php-cvs\pear\PEAR_Info\PEAR_Info-1.0.5.tgz done
Tag the released code with `pear cvstag package.xml'
(or set the CVS tag RELEASE_1_0_5 by hand)

only package.xml ends up in the resulting .tgz file.

I will check the source and do diffs and such and follow this up if I can myself.

I'm running WinXP Pro (without SP1) and am using the CLI binary.

looks like the bugs http://bugs.php.net/bug.php?id=20325 and http://bugs.php.net/bug.php?id=19906 had the same problem but were apparently solved. Don't know if this is related.

- Davey

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-10 15:05 UTC] pajoye@php.net
Hello,

I try to reproduce it on differents windows boxes without success.

pear install PEAR_Info-1.0.5.tgz works.

I use the tar command from unixtools, unrar and winzip to check the archive.

pierre
 [2003-05-10 18:36 UTC] pajoye@php.net
After some investigations done by Davey, it broke some time between: 200304240030 and PHP 4.3.2RC2 (April 28th).

something broke between 1.5 and 1.15.

I assigned this bug to Bertrand.

Is it possible to freeze it until 4.3.2 has been released (+a few weeks after)?

As it is used by the installer/packager, it will be hard to keep the distros safe.

Please note, this bug is weird and seems to exist only on some system (I cannot reproduce it on my XP/2K boxes), but using the revision 1.15 solves it.


hth

pierre
 [2003-05-10 18:43 UTC] pajoye@php.net
ERR, Assigned to Vincent :-))
 [2003-05-10 18:46 UTC] davey@php.net
the versions Pierre is talking about, are the CVS Revisions for Archive_Tar, placing Revision 1.5 from the 24 April snapshot into the 10th May snapshot means the tgz is created correctly.

One more thing to note, is that the package size does not (seem to) change (7KB when broken or not), and it just seems as though the other files are not acknowledged, is there some sort of TOC that could be corrupted?

- Davey
 [2003-05-11 09:18 UTC] vblavet@php.net
I confirm that I see the same problem on my system (win2k). 
The archive contains all the files, and seems to be readable and extractible by Archive_Tar. However Winzip or gnu tar sees only the package.xml file.

I'm working on that.

I already see one strange behavior while troubleshooting the problem. The Archive_Tar_1.0.tgz package released with the snapshot contains the Tar.php version 1.9 and not the stable version 1.5. It seems that Archive_Tar_1.0.tgz is not the good one, but an auto generated one ....

 [2003-05-11 11:28 UTC] vblavet@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

The bug is corrected in the last CVS version Tar.php 1.10.
The problem was introduced when adding the bz2 compression. When adding files in an existing archive, an invalid empty block (which normally indicates the end of the archive) is not removed between the existing files (here package.xml) and the other files.

http://cvs.php.net/co.php/pear/Archive_Tar/Archive/Tar.php?login=2&r=1.10
 [2003-05-11 14:58 UTC] davey@php.net
Just confirming that it is indeed fixed. Good job.

- Davey
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 27 14:03:37 2021 UTC