php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23508 Segmentation fault with data type in mssql
Submitted: 2003-05-06 11:14 UTC Modified: 2005-05-30 11:38 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: alietss at yahoo dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4CVS-2003-05-06 (stable) OS: RedHat 9.0
Private report: No CVE-ID: None
 [2003-05-06 11:14 UTC] alietss at yahoo dot com
Hi PHP people:
I have found a segmentation fault with httpd-2.0.45
php-4.3.2 freetds-0.62-dev on RedHat 9.0 TDS 7.0
against a Microsoft SQL Server 2000, the problem is
when some of the queries field is of type datetime
8...
I'm using freetds-0.62-dev with mssql native php extension
Here the apache error log...

httpd: read.c:365: tds_get_char_data: Assertion
`in_left < 4' failed.
[Tue May 06 11:05:27 2003] [notice] child pid 9064
exit signal Segmentation fault (11)
[Tue May 06 11:05:27 2003] [notice] child pid 9065
exit signal Segmentation fault (11)

I report this to freetds people too since I don't know who belongs the problem...
                           Any Ideas, Regards Aliet

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-06 12:11 UTC] fmk@php.net
Can you provide me with a small code sample to reproduce this error. I think it is a bug in FreeTDS, and would like to trace it.
 [2003-05-14 11:02 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2004-01-08 04:21 UTC] sebastian dot wiehe at qmarketing dot de
Anyone found a solution for that prob? I'm having exactly the same problems running mandrake 9.2, freeTDS 0.61, php 4.3.3.

By now, I found no one who could deal with this strange behaviour. If you need further information concerning that possible bug, please contact me via email!!!!

Thanks
 [2004-04-12 01:03 UTC] swingcoder at msn dot com
i met the same problem,
any one resolve it,
pls let me know via email above.
tks
 [2005-05-30 10:48 UTC] freddyz77 at tin dot it
Current version (0.63) do not contains that assert.

freddy77
(FreeTDS developer)
 [2005-05-30 11:38 UTC] tony2001@php.net
No PHP bug -> bogus.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 08:01:29 2024 UTC