php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #235 Dont work ereg,eregi functions
Submitted: 1998-04-03 00:06 UTC Modified: 1998-04-03 00:10 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: Lebedev at ural dot ru Assigned: rasmus (profile)
Status: Closed Package: Other
PHP Version: 3.0 Release Candidate 2 OS: SCO Open Server 5.0.0
Private report: No CVE-ID: None
 [1998-04-03 00:06 UTC] Lebedev at ural dot ru
I am use php as apache module (1.2.6)
with MySQL support, when I use ./Configure script only 
--with-apache=.. --with-mysql=.. In my php3 scripts
dont work ereg,eregi,ereg_replace etc.. functions.

When I Add to ./Configure flag --with-system-regex 
and rebuild my httpd ALL EREG Functions Work Fine!!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-04-03 00:10 UTC] rasmus
That's why you have the option of two different regex implementations.  Looks like you found a setting
that works, why fight it?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 06:05:52 2022 UTC