php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23335 ftp_chdir crashes Apache 2
Submitted: 2003-04-24 11:43 UTC Modified: 2003-04-24 20:50 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:3 (100.0%)
From: lionelenkaoua at chez dot com Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4CVS-2003-04-24 (stable) OS: XP
Private report: No CVE-ID: None
 [2003-04-24 11:43 UTC] lionelenkaoua at chez dot com
The execution of ftp_chdir() on windows Apache 2 with the latest PHP crashes Apache.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-24 11:56 UTC] sniper@php.net
Please provide us a test script which uses some public
ftp site (like ftp.funet.fi for example) so we can test
this ourselves too.

 [2003-04-24 12:10 UTC] lionelenkaoua at chez dot com
This simple connexion script crashes my apache.

$ftp = ftp_connect('my ftp server');
ftp_login($ftp, 'xx', 'xx');
ftp_chdir($ftp, '/'); // crashes

My ftp server is U-serv from RhinoSoftware. It's running under Windows
XP also.

Could you give login and password to test on ftp.funet.fi
 [2003-04-24 12:14 UTC] lionelenkaoua at chez dot com
I have tested with login:anonymous and my email for the password and it also crashes my Apache :(

So it seems not to be related with my FTP server
 [2003-04-24 12:37 UTC] sniper@php.net
Does not crash in Linux, so it's propably just win32 issue.

 [2003-04-24 12:57 UTC] lionelenkaoua at chez dot com
In the windows events viewer :

Type de l'?v?nement?:	Erreur
Source de l'?v?nement?:	Application Error
Cat?gorie de l'?v?nement?:	(100)
ID de l'?v?nement?:	1000
Date?:		24/04/2003
Heure?:		19:51:23
Utilisateur?:	N/A
Ordinateur?:	MEDIAPC
Description?:
Application d?faillante Apache.exe, version 2.0.45.0, module d?faillant php4ts.dll, version 4.3.1.1, adresse de d?faillance 0x000b7f04.

Pour plus d'informations, consultez le centre Aide et support ? l'adresse http://go.microsoft.com/fwlink/events.asp.
Donn?es?:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 41 70 61   ure  Apa
0018: 63 68 65 2e 65 78 65 20   che.exe 
0020: 32 2e 30 2e 34 35 2e 30   2.0.45.0
0028: 20 69 6e 20 70 68 70 34    in php4
0030: 74 73 2e 64 6c 6c 20 34   ts.dll 4
0038: 2e 33 2e 31 2e 31 20 61   .3.1.1 a
0040: 74 20 6f 66 66 73 65 74   t offset
0048: 20 30 30 30 62 37 66 30    000b7f0
0050: 34                        4
 [2003-04-24 13:03 UTC] lionelenkaoua at chez dot com
It's not a bug, my installation of php was not complete, because I forgot to replace php4ts.dll in my Apache bin/ directory when I changed my Php version.
 [2003-04-24 20:50 UTC] magnus@php.net
Not a bug => Bogus 
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 23:01:26 2019 UTC