php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23257 imap_fetchstructure crash
Submitted: 2003-04-17 05:55 UTC Modified: 2003-04-23 03:11 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: cwl_999 at hotmail dot com Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.3.0 OS: NT4.0 SP6
Private report: No CVE-ID: None
 [2003-04-17 05:55 UTC] cwl_999 at hotmail dot com
The following code causes PHP to freeze on the second imap_fetchstructure call even though there are more messages in the mailbox.

<?
	phpinfo();
	if ($mbox = @imap_open ("{10.5.0.4:110/pop3}INBOX", "asd", "asd"))
	{
		echo "LL";
		imap_fetchstructure($mbox, 1);
		echo "KK";
		imap_delete($mbox, 1);
		echo "JJ";
		imap_expunge($mbox);
		echo "HH";
		imap_fetchstructure($mbox, 1);
		echo "GG";	
	}
?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-22 02:18 UTC] cwl_999 at hotmail dot com
Tried the latest stable, same problem.

To my understanding, deleting and expunging message 1 should move all messages upwards (to fill the empty space) allowing me to reapeat the operations with the new message 1.

I've treid incrementing the message number, but this causes the routine to miss every other message.
 [2003-04-23 03:11 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

This is not a support forum and this is not a bug.
Please ask elsewhere how to use the imap_* functions.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 12 05:05:44 2022 UTC