php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23252 Incorrect MySQL client version compiled in PHP
Submitted: 2003-04-17 00:54 UTC Modified: 2003-04-24 04:08 UTC
From: j dot katarski at ecu dot edu dot au Assigned: georg (profile)
Status: Not a bug Package: MySQL related
PHP Version: 4.3.2RC1 OS: Windows XP SP1
Private report: No CVE-ID: None
 [2003-04-17 00:54 UTC] j dot katarski at ecu dot edu dot au
Using a MySQL 4.1 database, it's as simple as:
<?
     $conn = mysql_connect();
?>

This is will immediately fail with:
1249 - Client does not support authentication protocol requested by server. Consider upgrading MySQL client

This is a problem with a lot of applications, I believe due to changes with mysqllib.dll.

The solution for a MySQL driver I use, was to recompile, using the new MySQL headers and new mysqllib.dll

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-17 02:03 UTC] magnus@php.net
MySQL 4.1 won't be supported in 4.3. 
PHP5 snapshots have an extension called mysqli which is 
for MySQL 4.1 functions (mysqli_*). 
 [2003-04-17 03:02 UTC] georg@php.net
Works fine here [tm]

Please check your client version , with echo mysql_get_client_info().

 [2003-04-17 03:12 UTC] magnus@php.net
I was too fast there =) 
 [2003-04-18 12:48 UTC] georg@php.net
changed status to feedback

 [2003-04-23 00:15 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-04-23 00:44 UTC] j dot katarski at ecu dot edu dot au
<?
echo mysql_get_client_info();
$conn = mysql_connect("server.with.mysql4.1", "username", "password");
?>

Returns the following information:

3.23.49<br />
<b>Warning</b>:  mysql_connect() [<a href='http://www.php.net/function.mysql-con
nect'>function.mysql-connect</a>]: Client does not support authentication protoc
ol requested by server. Consider upgrading MySQL client in <b>my php filename</b> on line <b>3</b><br />

It was outlined earlier that PHP4 will *NOT* support MySQL 4.1.
 [2003-04-23 03:12 UTC] sniper@php.net
That's what you get when using beta/alpha software. Use a stable mysql release and it will all be fine.

 [2003-04-24 04:08 UTC] georg@php.net
In MySQL 4.1 they changed the authentication protocol and password() function.

To use 3.23 client library you must copy the mysql-tables from an older version into your datadirectory. As long 4.1 is still alpha we cannot provide a bundled library.
 [2004-07-15 10:20 UTC] arjen at mysql dot com
Simple solution: you can use the --old-passwords option in the MySQL 4.1 (or higher) server, to be able to connect from the PHP 4 mysql extension. See here for more info: http://dev.mysql.com/doc/mysql/en/Upgrading-from-4.0.html

The mysqli extension in PHP 5 speaks the new protocol.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 06 06:01:23 2019 UTC