php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23216 Cannot load library 'php_mhash.dll'
Submitted: 2003-04-14 21:09 UTC Modified: 2003-04-18 11:48 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: gabe at horizondatacom dot com Assigned:
Status: Not a bug Package: mhash related
PHP Version: 4.3.1 OS: Windows 2000
Private report: No CVE-ID: None
 [2003-04-14 21:09 UTC] gabe at horizondatacom dot com
I was attempting to load the library as normal under Windows 2000 from php.ini.  I get an error everytime saying that it could not load the library.  All libraries were extracted directly from the 4.3.1 package.

I converted everything back to 4.2.3 and it works fine.

:) Have Fun!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-14 22:47 UTC] gabe at horizondatacom dot com
I downloaded the installer straight from the website and ran accordingly.  Then I downloaded the package and installed that into the same directory that the windows installer installed to.  I made sure all extensions were properly installed.  When I tried to load a page with the new installation, I kept getting windows message box errors saying "Could not load extension 'php_mhash.dll'".  

Usually this error is reserved for when you have a version of an extension that is not compiled against the version of PHP that you are running. But since this came with a package distribution of PHP, I expect it to be compatable. So, I downloaded the PHP 4.2.3 package and installed into the same directory to prove that it is not a php.ini issue.  It installed correctly and all pages calling mhash() worked properly.  I believe someone may have grabbed the wrong file for inlcusion of this build. :) Happy Hunting!
 [2003-04-15 06:11 UTC] edink@php.net
Remembered to copy dlls\*.dll from the zip package to c:\winnt\system32 as described in the installation instructions?
 [2003-04-18 11:06 UTC] gabe at horizondatacom dot com
Library components were not loaded as I was supposed too..
 [2003-04-18 11:48 UTC] magnus@php.net
Not a bug => Bogus 
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 30 03:01:24 2020 UTC