php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23102 exif_read_data crash
Submitted: 2003-04-07 17:28 UTC Modified: 2005-02-01 22:50 UTC
From: php at mwi dot dk Assigned:
Status: Closed Package: EXIF related
PHP Version: 4.3.2-RC (latest CVS) OS: FreeBSD 4.8
Private report: No CVE-ID:
 [2003-04-07 17:28 UTC] php at mwi dot dk
Hello,

I have a problem with the exif_read_data function.

The browser just doesn't load content. Seems like php crashes.

The problem only occurs with some images.

I've uploaded an example:

http://www.opgavestyring.dk/11618.jpg

Code:

$sti = '11618.jpg';

if(file_exists($sti))
{
    $exif = @exif_read_data ($sti, 0, true, false);
    print $exif['EXIF']['DateTimeOriginal'];
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-07 19:22 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 20:02:09 2014 UTC