php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23099 4.3.1- libgds.so: undefined reference to `crypt'
Submitted: 2003-04-07 14:21 UTC Modified: 2003-04-25 04:00 UTC
Votes:3
Avg. Score:4.3 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: hasihola at cs dot tu-berlin dot de Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.3.1 OS: Linux 2.4.7-10
Private report: No CVE-ID:
 [2003-04-07 14:21 UTC] hasihola at cs dot tu-berlin dot de

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-08 09:55 UTC] kancil at ww dot tu-berlin dot de
I Don't Think that this is PEAR related,
I Tried the newest PEAR packages on PHP 4.3.1 but it don't solve the problem, i even tried to not use PEAR, but instead the normal interbase functions.
But if i do SELECT COUNT (*) with the same 'where' expression
it results in N row's, but if i try to fetch it, it doesn't have any content.
 [2003-04-08 10:05 UTC] mj@php.net
So it's a Interbase problem then.
 [2003-04-10 12:52 UTC] hasihola at cs dot tu-berlin dot de
Hi,
I just D/L the php4-STABLE, but it doesn't even make through
Configure, the errors are :
checking for InterBase support... yes
checking for isc_detach_database in -lgds... no
configure: error: libgds not found! Check config.log for more information.
----------------------------------------------------
Config log:
configure:37594: gcc -o conftest -g -O2  
    -L/opt/interbase/lib -lgds 
    conftest.c -lgds  -lresolv -lm -ldl -lnsl  1>&5
/opt/interbase/lib/libgds.so: undefined reference to `crypt'
collect2: ld returned 1 exit status
configure: failed program was:
#line 37583 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char isc_detach_database();

int main() {
isc_detach_database()
; return 0; }
-----------------------------------
I've tried this with 2 stable versions of Firebird:
FirebirdSS-1.0.0.796-0
FirebirdSS-1.0.2.908-1
I can't switch to BETA versions of Firebird

Thanks much,
Jerry
 [2003-04-18 08:39 UTC] daniela@php.net
These are two different problems.

It's better to set this bug in Compile Failure category.
Interbase related ----> Compile Failure

The compile issue you've received is true for Firebird. 
- Firebird users can't pass configure test. 
  libgds test require libcrypt too, otherwise it fails.
- Interbase users have no problems instead. 

The question about ibase_fetch_row sounds strange ....
it doesn't work  on some table only?
I' m using 4.3.1 + Firebird (without pear)
and I have no problem.
However, if you can reproduce your error about ibase_fetch_row
in a few lines of code, feel free to open a new bug. 
(see at http://bugs.php.net/bug.php?id=11176 as an excellent example of how to report a bug) 
 
 [2003-04-19 13:12 UTC] hasihola at cs dot tu-berlin dot de
The problem begun differently,sniper pointed the newest PHP version to try, in this new version i got problems with compiling the interbase extension, the funny thing is i got libcrypt on my System :( (and its on my ld path)
I posted my table structure on one of the previous messagess,
could you please try to use the table i posted ?
I've tried it with/without PEAR, and the Result are the same,no data can be retrieved, but the row count of the same Select statement is working alright.
Thanks Much in advance
 [2003-04-19 17:27 UTC] daniela@php.net
Maybe I don't explain me well ...

1) the compile failure exists for ALL Firebird users,
   it's our test for libgds in ./configure that is not  correct .
   If we don't fix it you couldn't compile php with Firebird
   anymore .... 
   this is why I turn your bug in compile error.
      
So right now let's solve the compile error ok?

2) Open a NEW bug for ibase_fetch_row (and without pear 100%).
   I need to reproduce the error you 're talking about
   for ibase_fetch_row but from your information I can't.
   All tests I 've done work good.


   
 [2003-04-23 04:04 UTC] sniper@php.net
Daniela, the problem is in ext/interbase/config.m4 so please don't make this a general "compile failure" report.

 [2003-04-25 04:00 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 10:03:03 2014 UTC