php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23083 on MSIE with zlib.output_compression=On some links do not work
Submitted: 2003-04-07 06:33 UTC Modified: 2003-04-23 10:52 UTC
From: miss dot parker at dialcom dot com dot pl Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 4.3.1 OS: linux (RedHat)
Private report: No CVE-ID: None
 [2003-04-07 06:33 UTC] miss dot parker at dialcom dot com dot pl
this is a very strange thing..

when I display pages on MSIE (ver eng 6.x, also checked one with lastest service packs, on win98) with php.ini: zlib.output_compression=On some links (about 10% of the links) on the page (always the same links in the page) don't work (after the click you see a blank page - no text), the same link on the same page (with the same URL), but placed in different place usually works - this is a simple page - no javascript/DHTML magic just a simple link  to a .php file, but when I check the same page with (Mozilla 1.3 or Opera 6.x) all links work just fine

when I set: zlib.output_compression=Off - all the links work fine also under MSIE

it runs on linux (redhat) under apache 1.3.27 + php 4.3.1 (zlib 1.1.3)

config script:
'./configure' '--prefix=/usr/src/apache_1.3.27' '--with-config-file-path=/etc/httpd/conf' '--with-apache=/usr/src/apache_1.3.27' '--disable-pear' '--without-mysql' '--disable-xml' '--disable-posix' '--enable-trans-sid' '--with-zlib=/usr' '--with-pcre-regex'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-21 09:21 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-04-22 05:04 UTC] miss dot parker at dialcom dot com dot pl
I tried the latest: php4-STABLE-200304220730
and the problem still exists

looking at the apache logs - looks like the page (that appears blank in IE) has been served OK, pressing CTRL+R makes the (blank) page to display correctly

it looks to me that the problem is somehow related with sessions, some pages on my site that requires login, are displayed incorrectly because of the error - but I cannot find the difference (in the PHP code of the pages) between correct and incorrect displayed pages

pages not depedent on session are not affected
 [2003-04-23 04:10 UTC] sniper@php.net
Just the normal cacheing problems with IE.
Not PHP bug.

 [2003-04-23 10:52 UTC] miss dot parker at dialcom dot com dot pl
ok, but why it happens with zlib.output_compression=On only?
with zlib.output_compression=Off works fine..
and why it is session dependend?

how to make it work fine under IE? send some special headers before sending the HTML?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Nov 27 18:01:25 2020 UTC