php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2307 Apache doesn't compile with PHP4 module
Submitted: 1999-09-15 15:28 UTC Modified: 1999-09-15 16:37 UTC
From: essiembre dot pascal at ic dot gc dot ca Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.0 Beta 2 OS: Linux
Private report: No CVE-ID: None
 [1999-09-15 15:28 UTC] essiembre dot pascal at ic dot gc dot ca
I followed the instructions in the INSTALL program carefully.  Everything worked exept the apache compile.  It works without the --activate option.  I am using a gcc compiler.


PHP OK-> ./configure --prefix=/www --activate-module=/usr/local/src/apache/apache_1.3.9/src/modules/php4/libphp4.a

APACHE NOT OK -> ./configure --prefix=/www --activate-module=src/modules/php4/libphp4.a
Configuring for Apache, Version 1.3.9
 + using installation path layout: Apache (config.layout)
 + activated php4 module (modules/php4/libphp4.a)
Creating Makefile
Creating Configuration.apaci in src
Creating Makefile in src
 + configured for Linux platform
 + setting C compiler to gcc
 + setting C pre-processor to gcc -E
 + checking for system header files
 + adding selected modules
    o php4_module uses ConfigStart/End
 + checking sizeof various data types
 + doing sanity check on compiler and options
** A test compilation with your Makefile configuration
** failed. This is most likely because your C compiler
** is not ANSI. Apache requires an ANSI C Compiler, such
** as gcc. The above error message from your compiler
** will also provide a clue.
 Aborting!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-09-15 16:37 UTC] rasmus at cvs dot php dot net
http://www.php.net/FAQ.php3#4.10
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 20:01:26 2019 UTC